Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
GIMP not showing Font correctly
Hello all,

I have a really annoying problem and I hope you can help me =)

I´ve installed a new Font in Windows (OpenClassic)

The Font is visible in GIMP, but it just looks like a standard Font.

In the attached images you can see how it looks in GIMP (wrong) and how it looks in word and every other program i tested (right)

Things I tested:
Deleting and Reinstalling the Font
Deleting and reinstalling GIMP
Deleting the Font Cache Folder
Adding the font manually to the specified Folders under Settings in Gimp

Sadly nothing seems to work =(

I hope you can help mit with this.

Best regards!

Attached Files Thumbnail(s)
Where can we download a copy of the font (assuming it's free?)

Edit: in the mean time got a .OTF from here.

I did a Gimp-only install and ame as you, displays as the default Sans Serif font.

Tried a system install and even though it looks OK in the font manager:

  1. There is a very obvious kerning problem (the digits aren't regularly spaced)
  2. The font manager is unable to display it with a test string I provide
I tried the font also and load it from :
I have the the same problem as KamiRyu37.
If I open the font up in linux kcharacter select, The characters are in a "Private Area" and for some reason Gimp does not see them - neither does Inkscape and LibreOffice.

Using Fontforge it is possible to copy those characters and paste into the start of the font where Gimp can find them.


As an example the font attached (remember to unzip it)

Since you are using Windows don't install this font, just put in your Gimp User profile font folder.

Attached Files
.zip (Size: 29.4 KB / Downloads: 10)
You are a life Saver!
Thank you so much.
This will be my last project with this Font then!

Forum Jump: