Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Resynthesizer/Python revisited
#1
Using Gimp 2.10.22 on knoppix 9.1

Reference our prior discussion pertaining to plug-in compatibility with python 2 vs python 3 that is included with various linux distributions.

Recently figured out what I had been doing wrong all along trying to get the Synaptic package manager working.  Great resource for the direct links to the repositories.

So, trying to make up for past deficiencies, I located a Python 2.10.8-2 which is specifically billed as being "python support for gimp"

Installed it, and how have a Python-Fu menu item in my Gimp >Filters menu.  Then placed the plugin-heal-selection.py, plugin-heal-transparency.py,  resynthesizer, and resynthesizer_gui items in my /.config/GIMP/2.10/plug-ins subdirectory.

Relaunched gimp, and behold  the menu items heal selection and heal transparency showed up in my Filters>Enhance menu.

But Resynthesizer did not show up in my Filters>Map menu.   I recall there being something about having to make the two Resynthesizer items "executable".  WHICH I BELIEVE all that entails is to go to Properties>Permissions>Execute and verify that the list box states  "Anyone".

Is that correct? Or have I been missing something more that is required?

Because when I try to use either heal selection or heal transparency in gimp, I get the following errors.

Heal Selection
[Image: fPQgu9z.png]



Heal Transparency
[Image: 5wDwSte.png]



And in both instances I additionally get the following  "procedure not found" error message:


[Image: dagcD7o.png]


So, that has me wondering......does the retro "Python for Gimp" addition that I made appear to be the right one? is there a better?

Have I  properly done what is required to make the Resynthesizer modules executable?

Have I muffed up something else?

As always, your time and thoughts are appreciated   Smile


Reply
#2
Well this is a merry-go-round Wink   Fortunately, I have a knoppix 9 on a usb stick, since it comes with nearly everything + the kitchen sink. Except of course resynthesizer.
Various file managers installed but I recommend krusader for checking permissions.

   

I tried 3 different compiles of resynthesizer / resynthesizer-gui and each gave the same error: not finding libgimp-2.0...  Looked for libgimp-2.0... and it is in the lib/i386 folder. It is a 32 bit Gimp
Run Gimp from a terminal and check for errors.
Using 32 bit plugins (attached) works here. I do not have gimp-python installed but Flters -> Map -> Resynthesize looks like this, and works as it should.

   


Attached Files
.zip   linux-resynth-32bit.zip (Size: 20.59 KB / Downloads: 10)
Reply
#3
(11-25-2021, 10:01 PM)rich2005 Wrote: Well this is a merry-go-round Wink   Fortunately, I have a knoppix 9 on a usb stick, since it comes with nearly everything + the kitchen sink. 

Fortunately, this should be the last (specific to resynthesizer)  time "around" for me, .  Your furnished solution works perfectly for me. I am both humbled as well as grateful for your help. 

So, if I follow your explanation properly,  despite having a 64 bit version of knoppix running,  they have bundled a 32 bit version of gimp with it?

Yes, the "kitchen sink" aspect is appealing,  as well as being able to browse the deepest darkest corners of the internet without worrying that I'm gonna pick up a bug unexpectedly.  Making changes that are permanent is a tad laborious having to remaster a complete new system, but as with all things for me the good  outweighs the bad.

Thanks for the custom compiled help!!


Reply


Forum Jump: