Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
error: possibly undefined macro: AM_PATH_GTK_2_0
#1
I am trying to compile GIMP git on Ubuntu-MATE 17.10 64bit:
Here is what I get:

Code:
I am testing that you have the tools required to build the
GNU Image Manipulation Program from git. This test is not foolproof,
so if anything goes wrong, see the file HACKING for more information...

checking for libtool >= 1.5 ... Major version might be too new (2.4.6)
checking for gtkdocize ... yes
checking for autoconf >= 2.54 ... yes (version 2.69)
checking for automake >= 1.13.0 ... yes (version 1.15)
checking for intltool >= 0.40.1 ... yes (version 0.51.0)
checking for xsltproc ... yes

I am going to run ./configure with the following arguments:

 

If you wish to pass additional arguments, please specify them
on the ./autogen.sh command line or set the AUTOGEN_CONFIGURE_ARGS
environment variable.


WARNING: aclocal's directory is /usr/share/aclocal, but...
        no file /usr/share/aclocal/glib-2.0.m4
        You may see fatal macro warnings below.
        If these files are installed in /some/dir, set the
        ACLOCAL_FLAGS environment variable to "-I /some/dir"
        or install /usr/share/aclocal/glib-2.0.m4.


WARNING: aclocal's directory is /usr/share/aclocal, but...
        no file /usr/share/aclocal/glib-gettext.m4
        You may see fatal macro warnings below.
        If these files are installed in /some/dir, set the
        ACLOCAL_FLAGS environment variable to "-I /some/dir"
        or install /usr/share/aclocal/glib-gettext.m4.


WARNING: aclocal's directory is /usr/share/aclocal, but...
        no file /usr/share/aclocal/gtk-2.0.m4
        You may see fatal macro warnings below.
        If these files are installed in /some/dir, set the
        ACLOCAL_FLAGS environment variable to "-I /some/dir"
        or install /usr/share/aclocal/gtk-2.0.m4.

configure.ac:590: warning: macro 'AM_GLIB_GNU_GETTEXT' not found in library
configure.ac:663: warning: macro 'AM_PATH_GLIB_2_0' not found in library
configure.ac:745: warning: macro 'AM_PATH_GTK_2_0' not found in library
libtoolize: putting auxiliary files in '.'.
libtoolize: linking file './ltmain.sh'
libtoolize: putting macros in AC_CONFIG_MACRO_DIRS, 'm4macros'.
libtoolize: linking file 'm4macros/libtool.m4'
libtoolize: linking file 'm4macros/ltoptions.m4'
libtoolize: linking file 'm4macros/ltsugar.m4'
libtoolize: linking file 'm4macros/ltversion.m4'
libtoolize: linking file 'm4macros/lt~obsolete.m4'
configure.ac:228: installing './compile'
configure.ac:93: installing './missing'
app/Makefile.am: installing './depcomp'
configure.ac:600: error: possibly undefined macro: AM_GLIB_GNU_GETTEXT
     If this token and others are legitimate, please use m4_pattern_allow.
     See the Autoconf documentation.
configure.ac:677: error: possibly undefined macro: AM_PATH_GLIB_2_0
configure.ac:759: error: possibly undefined macro: AM_PATH_GTK_2_0

Any ideas how to fix this?
Reply
#2
in my Gimp compiles, these symbols are defined in aclocal.m4, which is an autogenerated file
Reply
#3
(10-28-2017, 03:12 PM)Ofnuts Wrote: in my Gimp compiles, these symbols are defined in aclocal.m4, which is an autogenerated file

So would you suggest any recommendation?
Reply
#4
I don't know more than you about Gimp's build process and Linux build processes in general (autoconf, automake et al.). So, I would just do the usual, figure out what generates the file and how, and work back up to "make configure" (or is it "./configure"?) if necessary, trying to guess what is missing.

Or ask on the Gimp developers' mailing list. But, given that you can find executable versions, I assume you want more than just run Gimp, in which case figuring out the build process yourself is a good exercise.
Reply
#5
For future reference:

I think I found the solution:

SImply add
Code:
ACLOCAL='aclocal -I /gtk/share/aclocal'
before ./autogen.sh in gimp folder:
Code:
ACLOCAL='aclocal -I /gtk/share/aclocal' ./autogen.sh

the error seems to go away.
Reply


Forum Jump: