Gimp-Forum.net

Full Version: Python not working in 2.10.0 Windows
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
I installed GIMP 2.10.0 on Windows 10. During installation, I did select the option to install Python support. But for some reason, Python support is not working at all.
I do have Python installed and can run it in a terminal window just fine. However, GIMP isn't showing the Python-Fu console or any of my Python scripts in the menus at all.

During startup, GIMP shows errors in the console for all of my Python scripts:


Code:
Querying plug-in: 'C:\Program Files\GIMP 2\lib\gimp\2.0\plug-ins\python-eval.py'
C:\Program Files\GIMP 2\bin\gimp-2.10.exe: LibGimpBase-WARNING: gimp-2.10.exe: gimp_wire_read(): error
Querying plug-in: 'C:\Program Files\GIMP 2\lib\gimp\2.0\plug-ins\python-console\python-console.py'
C:\Program Files\GIMP 2\bin\gimp-2.10.exe: LibGimpBase-WARNING: gimp-2.10.exe: gimp_wire_read(): error
Querying plug-in: 'C:\Program Files\GIMP 2\lib\gimp\2.0\plug-ins\py-slice.py'
C:\Program Files\GIMP 2\bin\gimp-2.10.exe: LibGimpBase-WARNING: gimp-2.10.exe: gimp_wire_read(): error
Querying plug-in: 'C:\Program Files\GIMP 2\lib\gimp\2.0\plug-ins\palette-to-gradient.py'
C:\Program Files\GIMP 2\bin\gimp-2.10.exe: LibGimpBase-WARNING: gimp-2.10.exe: gimp_wire_read(): error
Querying plug-in: 'C:\Program Files\GIMP 2\lib\gimp\2.0\plug-ins\palette-sort.py'
C:\Program Files\GIMP 2\bin\gimp-2.10.exe: LibGimpBase-WARNING: gimp-2.10.exe: gimp_wire_read(): error
Querying plug-in: 'C:\Program Files\GIMP 2\lib\gimp\2.0\plug-ins\palette-offset.py'
C:\Program Files\GIMP 2\bin\gimp-2.10.exe: LibGimpBase-WARNING: gimp-2.10.exe: gimp_wire_read(): error
Querying plug-in: 'C:\Program Files\GIMP 2\lib\gimp\2.0\plug-ins\histogram-export.py'
C:\Program Files\GIMP 2\bin\gimp-2.10.exe: LibGimpBase-WARNING: gimp-2.10.exe: gimp_wire_read(): error
Querying plug-in: 'C:\Program Files\GIMP 2\lib\gimp\2.0\plug-ins\gradients-save-as-css.py'
C:\Program Files\GIMP 2\bin\gimp-2.10.exe: LibGimpBase-WARNING: gimp-2.10.exe: gimp_wire_read(): error
Querying plug-in: 'C:\Program Files\GIMP 2\lib\gimp\2.0\plug-ins\foggify.py'
C:\Program Files\GIMP 2\bin\gimp-2.10.exe: LibGimpBase-WARNING: gimp-2.10.exe: gimp_wire_read(): error

...and so on. Python worked fine in GIMP 2.8, but not now. Other plugins and Script-Fu works okay, just not anything in Python.
Quote:I do have Python installed and can run it in a terminal window just fine

Is that the Python that came with Gimp or is it another that you installed on the machine (if so, which version)?

Have you got the menu entry Filters>Python-fu>Console?
I had version 2.7.5 of Python installed already, and the one that came with GIMP is the same. Both versions work fine in a terminal window, just not in GIMP.

No, I do not have that menu entry.
Have you got a file lib/gimp/2.0/interpreters/pygimp.interp in the Gimp installation tree and what are the contents?
Yeah, it says:


Code:
python=C:\Program Files\GIMP 2\Python\pythonw.exe
/usr/bin/python=C:\Program Files\GIMP 2\Python\pythonw.exe
:Python:E::py::python:
Still think there is a mixup between the two Python interpreters. I would uninstall the independent one (and possibly reinstall Gimp if this is not enough).

I remember getting the two Python interpreters to work on Windows, but it was a hard battle, and IIR you had to install the independent one after Gimp.
That didn't work.
(05-09-2018, 10:47 PM)Someguy Wrote: [ -> ]That didn't work.

So, you uninstalled both your Python interpreter and Gimp, rebooted Windows, then reinstalled Gimp, and it didn't work?
That's right.
Same problem with Gimp 2.8?
Pages: 1 2