Gimp-Forum.net
Gimp 2.8 / 2.9 for linux users - Printable Version

+- Gimp-Forum.net (https://www.gimp-forum.net)
+-- Forum: GIMP (https://www.gimp-forum.net/Forum-GIMP)
+--- Forum: Gimp 2.9.x (https://www.gimp-forum.net/Forum-Gimp-2-9-x)
+--- Thread: Gimp 2.8 / 2.9 for linux users (/Thread-Gimp-2-8-2-9-for-linux-users)



Gimp 2.8 / 2.9 for linux users - rich2005 - 04-07-2018

For an ordinary user, at the moment using linux (I use Kubuntu 16.04), I can install either a Gimp 2.8.22 or a Gimp 2.9.9 but not both, since in linux they share the same directory locations.

One way round that as mentioned frequently here, is the regular Gimp 2.8.22 installed and a separate (portable) appimage for Gimp 2.9.9

Looking at the future, Kubuntu 18.04 with its newer packages will run Gimp 2.10  What if Gimp 2.8.22 is also required?

An alternative system to appimage is one called flatpak. This is the system that gimp.org in their wisdom (sometimes questionable wisdom) has gone for.

Does it work - Yes.

This a Kubuntu 18.04 VM and Gimp 2.10 https://i.imgur.com/rA6cHAl.jpg

The same VM running the Gimp 2.8.22 flatpak https://i.imgur.com/yueveYR.jpg

Downsides, lots and lots of cr*p installed just in order to run that gimp flatpak.


RE: Gimp 2.8 / 2.9 for linux users - grit - 04-07-2018

Why do you need both versions ?


RE: Gimp 2.8 / 2.9 for linux users - rich2005 - 04-07-2018

(04-07-2018, 12:54 PM)grit Wrote: Why do you need both versions ?

Probably for some time to come there are old plugins that will not work with Gimp 2.9/10

An example is the CMYK plugin separate+ Will it ever be fixed / replaced? Might never be.

Some graphic tablet users go back even further. Gimp 2.6 graphic tablet support frequently works better than Gimp 2.8.

All depends what you want / what you use Gimp for.


RE: Gimp 2.8 / 2.9 for linux users - Xxxx - 04-18-2018

Use Appimage for 2.9/2.10!