Gimp-Forum.net
Can't export individual layers!! - Printable Version

+- Gimp-Forum.net (https://www.gimp-forum.net)
+-- Forum: GIMP (https://www.gimp-forum.net/Forum-GIMP)
+--- Forum: Gimp 2.8 questions (https://www.gimp-forum.net/Forum-Gimp-2-8-questions)
+--- Thread: Can't export individual layers!! (/Thread-Can-t-export-individual-layers)



Can't export individual layers!! - baobaodarcy - 11-08-2019

I have a Mac, and wanted to export individual layers.  I tried to install the plug-in Export Layers following the instructions for Mac.  Tried versions 3.1, 2.1 and 2.0, by following the directions and moving the two files into the Gimp plug-in folder on my computer.  Nothing worked, so I deleted everything in the plug-in folder, and decided to start over and that I'll just have manually export layer by layer.  However, I can't even export anything as a PNG file anymore.  I tried restarting my computer and everything. When I try to Export, I get the error message:

The given filename does not have any known file extension. Please enter a known file extension or select a file format from the file format list.

1. There was nothing in the file format list when usually I see all the options like jpg, png, etc etc

2. I literally tried to save the file type as:
wind1.png 
with no spaces or anything... 

Thanks so much for your help in advance!!


RE: Can't export individual layers!! - akovia - 11-08-2019

@baobaodarcy

It really sounds like you deleted the system Plug-ins folder and not the user Plug-ins folder.

Try reinstalling gimp and see if that doesn't fix that problem. Then we can help with the plugin that's not working.


RE: Can't export individual layers!! - baobaodarcy - 11-09-2019

(11-08-2019, 11:21 PM)akovia Wrote: @baobaodarcy

It really sounds like you deleted the system Plug-ins folder and not the user Plug-ins folder.

Try reinstalling gimp and see if that doesn't fix that problem. Then we can help with the plugin that's not working.

Thanks for your help!  I trashed and emptied trash for GIMP 2.8.22 dmg, restarted my computer, and redownloaded GIMP, but same issue and error message: The given filename does not have any known file extension. Please enter a known file extension or select a file format from the file format list.Cry


RE: Can't export individual layers!! - Ofnuts - 11-09-2019

I assume that the file format list (bottom left of export dialog) is empty?

Go to Edit>Preferences>Folders>Plugins. This should list two directories, one being where Gimp is installed. Navigate to that directory with a file explorer. It should contain a bunch of executable files named file-<some image type>(file-png, file-jpeg...). Is it the case?

If this is true and Gimp still doesn't work, rename your Gimp profile and restart Gimp.


RE: Can't export individual layers!! - baobaodarcy - 11-09-2019

(11-09-2019, 06:27 PM)Ofnuts Wrote: I assume that the file format list (bottom left of export dialog) is empty?

Go to Edit>Preferences>Folders>Plugins. This should list two directories, one being where Gimp is installed. Navigate to that directory with a file explorer. It should contain a bunch of executable files named file-<some image type>(file-png, file-jpeg...). Is it the case?

If this is true and Gimp still doesn't work, rename your Gimp profile and restart Gimp.

Thanks for all of your help Ofnuts and akovia!  Really appreciate it.  I made a stupid mistake in my plug in folders in Gimp by accidentally duplicating the plug in path.  I reset it, reinstalled Gimp, and then installed the newest Export Layers plug-in by following the MacOS instructions, and it worked!