Gimp 2.9 color blending problem - Printable Version

+- (
+-- Forum: GIMP (
+--- Forum: Gimp 2.9.x (
+--- Thread: Gimp 2.9 color blending problem (/Thread-Gimp-2-9-color-blending-problem)

Gimp 2.9 color blending problem - mholder - 12-30-2017

Perhaps it is best to watch this video first (if you haven't seen it yet) to understand what I am having an issue with.

In Gimp 2.9 I did a test with an image in 32 bit float and linear color space, although the same problem exists in 8 bit.
I start with a simple image:
In a new layer using the 2.9 'normal' default layer mode, painting new colors lines has this effect:
This is correct.  If you look around the edges of the colors, they blend correctly.
But if I paint directly in the same layer, I get the dark outlines:
In other words, the new layer modes work correctly, but if colors are painted on the same layer, the colors do not blend correctly.

Anyone know what I can do to fix this?  Should I download a different color space, or is this just a hard-coded flaw?

RE: Gimp 2.9 color blending problem - rich2005 - 12-30-2017

It has been fixed. A RGB vs Linear issue. Not limited to Gimp

Enable Image -> Precision -> Linear
Make sure the paint tool is set to 'Default' (not legacy)
and I think the layer mode as Default as well.


RE: Gimp 2.9 color blending problem - mholder - 12-30-2017

I just now (just now!) realized there is an option to choose between default and legacy paint modes.  I never gave it a moment of thought and was trying to figure out what was going wrong for quite awhile.
Also, Gimp 2.9 correctly correctly blurs in sRGB mode without having to convert to linear light, so long as the paint mode is 2.9 default.  It also works correctly in 8 bit.  Things like pattern stamping are also affected.  I can't imagine any reason why I would use the old 2.8 modes anymore.