Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Portable Gimp 2.9.9 for linux
This is great. Thanks for putting this file together. I have been using Gimp 2.9.7 from the gimp-edge repo and I had no problems with it. This morning I found an update for Gimp in my update manager, and I applied it, only to find that there is now a dependency issue with libbabl. Hopefully this will be fixed soon, but as for now I had to uninstall Gimp 2.9.7 and revert to the last version in the repo, which is 2.8.16! Very disappointing..

In any case, this portable build now makes it possible to use the otto-kesselgulasch gimp-edge version without aches and pains. @rich2005 You're the hero of the day! Many thanks.
gimp-edge also maintains babl and gegl both updated on 26/10. So normally you should have updated the lot...
There is a dependency issue with the 'buntu libraries. libbabl-1.36 called as dependency, libbabl-1.35 in repo breaking the amd64 build earlier today.

Looking at the gimp-edge repo gimp-2.9.7 was updated again about 2 hours ago (from time of writing) maybe that has fixed it.

Worth trying a reinstall.

Remember this portable version is really meant as an addition to Gimp 2.8.22 not really a replacement.

edit: Up and running again, at least in 'buntu 16.04
I am having issues with the G'mic filter.  The filters themselves work, but I am unable to enter info with the keyboard.  I was wondering if it was just my computer or this is something related to QT.  Is anyone else having this issue?

Attached Files Thumbnail(s)
Yes, I have noticed that before, but never got around to investigating.

I do have files missing, I can get it working but the new 'assembled' appimage with additional files is smaller than the previous version.

That is always very suspicious. Give me a day to check things out & test and I will post an update (maybe)

edit: Ok updated the file I posted this morning with the additional files d... thing like pinocchio's nose, grow & grows

The same download link that is in the first post.
Yes it works. THanks!
I tried the 2.10rc following the instructions on this page:

First I removed 2.8 using the software manager, renamed by .gimp2.8 folder just as a backup to be safe

Actually I'm using Mint, but I think it should work; however, when I try to start Gimp, it keeps starting the version that rich2005 provided.  Where in the world is the normal Gimp program?  I looked in the usr/bin and the bin folder, but I can't find it.
In a terminal, if you enter type gimp what is the answer? And if you enter readlink -e $(type gimp))?

(03-30-2018, 08:38 PM)mholder Wrote: It says:
The program 'gimp' is currently not installed. You can install it by typing:
sudo apt install gimp

My mistake was removing 2.8 from the software manager before trying the 2.10 ppa.  THen I tried to purge the 2.10 ppa.  I should not have done that.  Now I cannot re-install Gimp via the software manager.

And I must stop messing around now.  I have screwed up this Linux stuff so badly in the past that I needed to totally re-install the OS.  This has happened so many times I fear doing anything more.  I still have rich2005's 2.9.9 and I guess I just have to wait.

Ok.  I got 2.8 back by getting dependencies and stuff (and Gimp 2.8)on the Synaptic Packing Manager, and now I am not touching anything.  

Hopefully sometime in this decade  the Software manager will be updated and I can try out layer group masks.  OR better yet, maybe someday I will find a tutorial for compiling Gimp that was written by a normal person and makes sense.

Forum Jump: