Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Clone tool pixelated at edges
Can anyone help. My clone tool in gimp 2.10 has become pixelated at the edge when I want a smooth copy of an image. It sometimes works but then becomes pixelated. I recently uploaded a large tiff file to my artwork which seemed to cause the problem but have since deleted the tiff. However, it still keeps happening which means that I cannot clone artwork. Is there something in the clone setting I can alter.
Any help much appreciated.
Do you have hard edges toggled on? These some options using the same hardness 100 brush. The brush does count, I usually use a fuzzy brush when cloning. Look at dynamics as well, a pencil dynamic gives little anti-aliasing.


Artwork? Are you using a graphics tablet? Gimp has separate settings for tablet and mouse. Use the appropriate device to
Many thanks for this. However, it's still a little pixelated even using the pencil dynamic and hard edge off. Also, the fuzzy brush does not work. I think it is a more generic problem. Someone has suggested to me that I need to update my operating system to 10.14.4 on my mac then de install gimp 2.10 and re install it? Don't know if you think this is a good idea?
I was assuming a general problem and not Mac specific. Not many Mac users visit this forum. Very strange that a fuzzy brush does not work.

Not able to comment on upgrading anything on a Mac, from the reports I see, more often breaks than fixes. Smile
[attachment=2852][attachment=2852]Hello Rich,
I didn't realise that not many mac users use gimp. I've upgraded my os system and the clone tool still doesn't work. It's less fuzzy around the edges thanks for your help but when I zoom in to the image its pixelated. I've enclosed an image to show what is happening. I'm really concerned as I have a number of fully worked images which need some corrections but without the clone tool working I cannot complete them.
Hopefully, you can open the image. I didn't know how to place it in the body of the text.

Attached Files Thumbnail(s)
That looks like a brush outline to me.  Not one that I have. You need a screenshot like this - full interface.


Edit: Just noticed that shows the paint tool. My bad, trying to combine screenshots. It was made using the clone tool, the hardness / force have that effect.
Same  brush - same size - same clone source. Various hardness and force.
Thank you for your time on this one. I think the system is corrupted as I'm definitely using the full round circle and understand the force and hardness aspects. The other issue is when I use the softer circles next to the full circle, the same image appears are a roughened edge circle. 
Further, the tool options box started appearing in the top left of the screen and I think that there may be some corruption of the program which I cannot get rid of. I've tried de installing and re installing but the blogs I've read say this may not help as if there is a fault, gimp will revert to that fault. Unless there is a better way of de installing. I think it is a fault in the system since I updated my os system on the mac as gimp was working perfectly a couple of months ago. It's also making the same mistake on another mac computer we have which has been updated.
I'll try and show you again with a full screen shot. I'm a bit of an oldie so not so great with technology but I know gimp fairly well after using if for a number of years.

Attached Files Thumbnail(s)
Further to last email and reading blogs it looks like gimp 2.10 isn't always behaving itself with the latest os systems on Macs. So I have gone back to re installing gimp 2.8. I've then copied across my graphics files as pngs from 2.10 into 2.8. I've also imported the same large jpeg images I was using in 2.10 into 2.8 and found that if I scaled them down that they remained much sharper in 2.8 on the mac than working in 2.10.
Therefore I am going back to 2.8 (which for anyone reading this thread, you will need to temporarily unlock your privacy/firewall to allow a non apple application in for the 2.8). Although I'm going to miss the better tools in 2.10, my images are sharper and hooray the clone tool works perfectly.
Many many thanks for trying to help me with this problem Rich. I hope this thread is useful to other gimp users
Just to tidy up, and a reason for giving all the information about any problem. Otherwise the answer you get is an educated guess at best.

The OP last screenshot gives some, but not all of the information. Where are the layers? Top of the window reports 91 of them.

Still a guess but I can now look at how a layer mode might give rise to that clone tool effect.


Using a hard-edge brush (with various tool hardness values) cloning into a transparent area. If the layer is in Dissolve mode gives that effect.

Forum Jump: