Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Binary Comment appears in Image Properties after using GIMP
#1
           

I am using GIMP 2.10.24 on Windows 10 64bit.

Until recently I was using GIMP with images from a Nikon D500.  When exporting images I have the "Save Exif data and Save XMP data" checked.
I use these exported images to upload to iNaturalist.  I've never had an issue.
Now I am using a Canon EOS 5 to GIMP images. As above, when exporting images I have the "Save Exif data and Save XMP data" checked.
When I upload images from the Canon camera that have been GIMPed to iNaturalist, I get a "binary comment" on the images I've uploaded.  

If I look at Properties-Details on a GIMPed Canon Image, "binary comment" is listed in the Title and Subject.  When looking at the same image before it is GIMPed, there is nothing listed in Title and Subject.
Looking at original and GIMPed images from the Nikon camera nothing is ever listed in either Title or Subject .

Attached are some screen shots.

I have changed the following in GIMP - Edit-Preferences-Default Image-Comment to have nothing in it.  This made no difference.  Still get the "binary comment"

What is causing the "binary comment" ? It is tedious to have to delete it from every image I upload to iNaturalist.

If any other information is needed, let me know.
Thank you for your review.
Reply
#2
Can you take an XCF of your images, crop it to something small (200x200 for instance) (make sure the Crop tool  has option Delete cropped pixels), save it as XCF, and attach it here?
Reply
#3
(09-22-2022, 10:40 PM)Ofnuts Wrote: Can you take an XCF of your images, crop it to something small (200x200 for instance) (make sure the Crop tool  has option Delete cropped pixels), save it as XCF, and attach it here?

Attached is an image that I cropped with GIMP, checked the "Delete cropped pixels" and saved as an XCF.

I hope that I did that correctly. If not or if anything additional is needed, let me know.

Thank you.


Attached Files
.xcf   B47A0283 - Copy1.xcf (Size: 258.05 KB / Downloads: 10)
Reply
#4
(09-23-2022, 12:50 AM)sjt619 Wrote: Attached is an image that I cropped with GIMP, checked the "Delete cropped pixels" and saved as an XCF.

I hope that I did that correctly. If not or if anything additional is needed, let me know.

Thank you.

Um...
yes it's in there (Image > Image Properties) on the tab Comment
   

and when exporting
   

May be the setting on your camera like inputting the name, and so are not empty, did you check on your camera? https://i.ytimg.com/vi/rlLB1zGw1qw/maxresdefault.jpg did you enter any data?
Or do you pass by another software before GIMP? If raw photo, yes you need, if so which one?
Reply
#5
This is an issue related to the Exiv2 library.
Found in gimp development code: https://gitlab.gnome.org/GNOME/gimp/-/bl...data.c#L99
Reply
#6
(09-23-2022, 06:24 AM)tmanni Wrote: This is an issue related to the Exiv2 library.
Found in gimp development code: https://gitlab.gnome.org/GNOME/gimp/-/bl...data.c#L99

From reading the info in the link, is this something that will be changed in the future?

I had also checked all the camera settings and couldn't find any additional wording added anywhere and GIMP is the only software used.
Reply
#7
Did you set the camera to add a comment in your images? Is the camera set up in a specific language? It could be the Exiv2 library not understanding some national encoding.
Reply
#8
(09-24-2022, 12:22 PM)Ofnuts Wrote: Did you set the camera to add a comment in your images? Is the camera set up in a specific language? It could be the Exiv2 library not understanding some national encoding.

I have doubled checked each camera setting and cannot find anything that has any comments added to images and there is also nothing in copyright info settings. They are blank.  The language on the camera is set as English.

Thanks.
Reply
#9
(09-26-2022, 06:51 PM)sjt619 Wrote:
(09-24-2022, 12:22 PM)Ofnuts Wrote: Did you set the camera to add a comment in your images? Is the camera set up in a specific language? It could be the Exiv2 library not understanding some national encoding.

I have doubled checked each camera setting and cannot find anything that has any comments added to images and there is also nothing in copyright info settings. They are blank.  The language on the camera is set as English.

Thanks.

Maybe try to put just a space (like a space between 2 words) on these camera settings
Reply


Forum Jump: