Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Characters interface too small
#1
Hello everyone, it's my first post.

I've been using Gimp (2.8 - 2.10) for a while, but I have problems with the 27 "(2560 x 1440) screen of my iMac. For my eyes, the fonts of the interface have become too small. I tried to change the screen resolution but the result did not like. I'm looking for a configuration file where I can edit a bigger font size. I also asked for other forums but I did not find a solution.
Thank you.
Reply
#2
Saw your post on pixls.us and possibly the last (#6) answer is worth a try.

The attached theme is an ancient one that I still use with my linux Gimp 2.10 - not black because I hate black Wink

Normally the font is commented out, but as an experiment, upped to size 18 in the gtkrc file. Easily edited to another size.

Unzip, put the folder 3-samj in your Mac Gimp User themes folder. Start Gimp and in Edit -> Preferences -> Themes and select it. 
The Icons settings are still independent and need to be increased in size from the Edit -> Preferences -> Icons settings.

Give it a try as an experiment. Might/might not work, who knows?


Attached Files
.zip   3-samj.zip (Size: 23.3 KB / Downloads: 24)
Reply
#3
Thank you, you're so kind.
I followed your instructions, Gimp sees the new "3-samj" theme and loads it. But the size of the characters always remain the same.
I've tried both with 2.10 and 2.8, but it's the same thing.
Thanks, I'll try again ....
Reply
#4
Try to find the gtkrc file of the theme you use.
(can't help with locating that one, don't have a Mac).

Once you have it look for a line like this
Code:
GimpDock::font-scale = 0.8333
Change the scale to something larger like 1.0
(If there is a # at the beginning of the line , remove it)

Hope that helps. Wink

Regards
nelo
Reply
#5
Thank you @nelo, I tried it but it does not work for me.
Reply
#6
On another site they suggested that I add these lines of code in the gtkrc file of my favorite theme and it works!
Code:
style "user-font"
{
    font_name="Arial Bold 14"
}
widget_class "*" style "user-font"

Thank you all for the aid received.
Reply


Forum Jump: