Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Export Layers Plugin not working with 2.10?

This is quite useful but as of 2.10 I'm unable to see the File - Export Layers To / Export All Layers after pasting the PY in plugins folder along with its export_layers folder. Alternatives, fixes or any news for its fixing?
Maybe reinstall it properly from the ZIP? This isn't a single-file plugin and it is likely that you missed something.
A quick test and it works here.

Did you get the latest version from

Did you put it in C:\Users\your-name\AppData\Roaming\GIMP\2.10\plug-ins ?

If that is ok you might have inherited some settings from Gimp 2.8.

Go into C:\Users\your-name\AppData\Roaming\GIMP\2.10 and delete the file pluginrc the one shown here:

Then start Gimp and it will re-register the plugins and make a new pluginrc file.
Fantastic ! That was another essential add-on i really wanted.
Now i have no more need to have a seperate 2.8 installed.

Gimp 2.10: im all yours now ! <3

I tried everything mentionned above, but still the plugin doesn,t show on gimp 2.10.

When I open pluginrc I can see my normalmap plugin, but nothing appears for my export_layers. And they are both in the same folder (C:\Users\USERNAME\AppData\Roaming\GIMP\2.10\plug-ins).

Any other Ideas?

Thank you.
Just a check: You are using the latest version from github and not the link from gimp-registry. Use this one

Usual problem, I can not replicate the issue.

screenshot of gimp 2.10 plug-ins folder

screenshot of pluginrc

You could try deleting pluginrc and let Gimp scan the plugins again or if you installed Gimp within the last 5 or 6 days might be the version of Gimp 2.10. (gimp installer "...setup-1.exe")
Yes sorry it seems to have been way older version.
for latest

I see the menus now
I had this issue and couldn't get it to work even with the latest version. Switched to a slightly earlier installer file of 2.10 ("gimp-2.10.0-x64-setup"/28-Apr-2018 from and now it works and I have the export layers menu options.
The owner fixed this issue (version 3.2) and even added a Windows installation wizard.

Issue #57: Version 3.1 does not work with GIMP 2.10.0

Quote:The reason why the plug-in no longer works is because the file assumes that export_layers subdirectory is in the same directory. This may also be the reason why the Python-Fu console does not show up.

It seems that the plugin was looking for the included directory but could not locate it.
I faced that problem too, but everything was fine until Windows April Update came out. Now most of the GIMP plugins show pretty poor appearance

Forum Jump: