Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Feathering won't turn off
I'm trying to crop the white border around this hat.  I used select-by-color with a very high threshold to select anything with white in it.
You see that there are some areas inside the hat selected.

[Image: nDLSdiCvZMnQPuwtNws-dy8LQcZBxLXrtpSXYCoj...dnWyp3rqC5]

I invert the selection with ctrl-I, then use "shift" to add the selected area to the selection.  (Curiously, the tool shows that it's in mode "replace", which it isn't, as you'll see in the next photo.)
[Image: cbSqTWa10_h2y5OwNtA9qGgc8tvvYpCfnuiV0Sf2...sScjp9_Xc4]

The pixels inside that parallelogram have been added to the selection:
[Image: JXk7kLz-pxD_WlYlBr26ek6UlVE3MTN18S8COc2E...0G7Tu-4hum]

If at this time I delete the selection, notice the dark smudges inside the hat (one is the upper-left corner) where it doesn't remove all the color.
It appears to be feathering.
[Image: ENysZyU7aWhHSLKYMu_3HJAg9KhdEVsCXK-I1nk6...RtdNYfKtsG]

Undo, ctrl-I, delete the white: also deletes the same amount from the hat as was left behind in the previous delete:

[Image: 0igCdYU7Eq6BsmovxwdUcyExK42TGKpMXpZ96EFU...GCi-eK8JGa]

This has got me totally stuck!  I've tried turning antialiasing on and off, tried using "subtract" mode instead of "add" mode--no matter what I do, I can't get GIMP to delete just the area inside the selection.  Note feathering is turned off both of all the selection tools used.
I'm on a tight deadline and have no way to proceed.
Replied here:

(Same question asked in 2 places)

Forum Jump: