Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Font issue
#1
Hi, I have just downloaded Gimp 2.10 but when opening the program it is shows squares with numbers inside, instead of letters/text.  I am using a MacBook Air 2020 running MacOS Big Sur 11.4

I presume this is a font issue, how best do I resolve this. 

Thanks
Mark
Reply
#2
Is this for all fonts ? Are some OK ?

Is it this problem https://gitlab.gnome.org/GNOME/gimp/-/issues/6520  ?

also Type 1 fonts see: https://helpx.adobe.com/fonts/kb/postscr...at%20fonts. are no longer supported.

Just in case it is a localisation issue look in the Preferences menu ( I think in MacOS it is found in the most left hand menu Gimp ???)  Then check in the Interface and the Language setting.

   

Edit: Got my old MacOS VM going (not bigsur) and I do not know if it helps but try changing the language from default <> to country or vice-versa. See if it makes any difference.

It can be a case of touch and guess Wink

   
Reply
#3
Hi, the problem is with all fonts. all menu wording is in a font that will not display so I can't navigate anywhere in Gimp.
Is there any way I can change the font display from my preferences in applications or some place ?

Thanks
Reply
#4
(08-09-2021, 07:03 PM)MDgimpboy Wrote: Hi, the problem is with all fonts. all menu wording is in a font that will not display so I can't navigate anywhere in Gimp.
Is there any way I can change the font display from my preferences in applications or some place ?

You should be able to find that menu from the position in the drop down menus, it is not impossible.

However the language setting is held in a file gimprc which is in your Gimp profile folder. A text file, you can edit it.

I only have an old MacOS VirtualMachine, My usual OS is linux.  The top shot is the MacOS gimprc file, the bottom is my linux file. 
Try either of those (language "") or (language "en_GB")  might / might-not work.

Otherwise  I do not know. You could try renaming the 2.10 folder to say 2.10-backup and let Gimp create a new default one - a long shot.

   
Reply


Forum Jump: