Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Fonts won't leave Gimp
#1
Hi All,
Can anybody suggest what am I missing, here? (Apart from the good sense to quit when I'm beaten, I mean).

I've got around again to investigating the 'Gimp only shows the default font when I try and use a font' problem on Windows 10, as shown in this thread: Gimp-Forum – Fonts Can't Be Used 

However, I don't seem to be able to clear the fonts I'm investigating out of Gimp!


.webp   Gimp fonts list 02.webp (Size: 5.47 KB / Downloads: 20)

The fonts are DEFINITELY NOT IN: 
C:\Windows\Fonts
C:\Users\QuinB\AppData\Local\Microsoft\Windows\Fonts
C:\Users\QuinB\AppData\Roaming\GIMP\2.10\fonts
C:\Users\QuinB\AppData\Roaming\GIMP\2.10\fonts_storage§
%PROGRAMFILES%\GIMP 2\share\gimp\2.0\fonts
C:\Program Files\WindowsApps

Listed in Edit > Preferences > Folders > Fonts
§ Referenced by the Sean Bogie, MareroQ, Ofnuts' addonCollectionManager-3.0

The Windows services
Windows Font Cache Service
and 
Windows Presentation Foundation Font Cache 3.0.0.0
were disabled, the system rebooted and 
C:\Windows\ServiceProfiles\LocalService\AppData\Local\FontCache and C:\Windows\System32\FNTCACHE.DAT deleted (and verified as deleted) before a further reboot and restart of the above services.
(I've even tried refreshing the fonts in Gimp after many restarts of the same)
And yet the fonts are still listed on Gimp, as shown above.

Again, can anybody suggest what I'm missing???
Reply
#2
Sometimes fonts misbehave because the font author has not a good job - does not conform to spec.

Examples:

file name: 17147___.TTF
font name: Oberon LET

ile name: Mom t___.ttf
font name: Mom's_Typewriter
displays after zzzzzzz

Sometimes the fonts are there, just with an unexpected name, file name, or position in the fonts list.
Reply
#3
(02-09-2020, 07:48 PM)Blighty Wrote: Sometimes the fonts are there, just with an unexpected name, file name, or position in the fonts list.

Ah, the fonts are listed just where they should be, right enough, it's getting rid of the listing that's the issue. They're not available anywhere on the system (that I know of and that's my issue)
Reply
#4
I have seen bug reports about fonts with the #1 ..etc suffix attached. Maybe reverting to the system default when clicked.  Seems to be a combination of a poorly made font + the fontconfig library lagging behind Window changes.

You could try looking in C:\Windows\WinSxS although AFAIK the fonts there are all system fonts, but who knows.
example: https://i.imgur.com/AYv5L9y.jpg

That Farm House font? Commercial? All I could find was a $13 download so not able to check. As Blighty wrote, the internal font name(s)  usually different to the file name.

Otherwise, are you using some sort of font provision service ? These seem to use their own cache.
Reply
#5
(02-10-2020, 09:12 AM)rich2005 Wrote: ... the fontconfig library lagging behind Window changes.

You could try looking in C:\Windows\WinSxS although AFAIK the fonts there are all system fonts, but who knows.
example: https://i.imgur.com/AYv5L9y.jpg

That Farm House font? Commercial? All I could find was a $13 download so not able to check. As Blighty wrote, the internal font name(s)  usually different to the file name.

Otherwise, are you using some sort of font provision service ? These seem to use their own cache.

F:\Program Files\GIMP 2\var\cache\fontconfig\<longname>-x86_64.cache-7 contains a reference of C:/WINDOWS/fonts/FarmHouse Regular.otf and related fonts, although the fonts are no longer anywhere other than a holding directory off my working area in Users\QuinB\Documents\.

There's nothing obvious off the WinSxS tree; I dropped to a system permissions command line and checked manually, in the end.

Farm House is commercial, but try https://www.1001fonts.com/nubian-font.htm, which just happens to be on the screen right now and showing the original 'system font only' problem. Interestingly, Nubian Regular is not present in C:\Windows\Fonts, but Nubian Shadow Regular IS. Stored copies show that the filename and font name are both sensible. 
Whatever it is I've broken, it's a good 'un.

Font provision service: no. I import ad hoc fonts to a specific holding area, extract and then tidy away with inhouse batch files.
Reply
#6
Just been having a look, found a free FarmHouse that is otf. Not the same as your installation but does exhibit a 'changed' font name in Gimp: https://i.imgur.com/TWVmndb.jpg  Indicates a less than wonderful font structure.

..but installed in Windows, fonts only shows the same as previously. Uninstall from Win fonts and the font goes from Gimp.
The only strange thing, with the fonts installed,  a Windows search for *.otf does not show anything in C:\ https://i.imgur.com/8Zc5Q4K.jpg but then I am a linux user and might be missing something.

Gimp installed in F: ? Have you tried renaming F:\Program Files\GIMP 2\var\cache\fontconfig to disable it. Guessing it contains hard links to non-existent files.

edit: That is strange, I do not seem to have a ..\Program Files\GIMP 2\var\ on my installation.
edit again: That reported as a bug https://gitlab.gnome.org/GNOME/gimp/issues/2574
edit once more: Gimp picky about fonts Wink This the Nubian font you referenced. nubian-shadow uses system default.  https://i.imgur.com/n2wv0Pw.jpg   Probably can be fixed with FontForge.
-----
as an example Nubian-Shadow re-built with fontforge. (zipped & attached Better give it a try in Win10 Wink https://i.imgur.com/42C6KVY.jpg )
If you paid money for Farmhouse, then get hold of the author and ask for a refund or a fix


Attached Files
.zip   NubianShadow.zip (Size: 25.68 KB / Downloads: 3)
Reply
#7
(02-10-2020, 12:03 PM)rich2005 Wrote: Just been having a look, found a free FarmHouse that is otf. Not the same as your installation but does exhibit a 'changed' font name in Gimp: https://i.imgur.com/TWVmndb.jpg  Indicates a less than wonderful font structure.

..but installed in Windows, fonts only shows the same as previously. Uninstall from Win fonts and the font goes from Gimp.
The only strange thing, with the fonts installed,  a Windows search for *.otf does not show anything in C:\ https://i.imgur.com/8Zc5Q4K.jpg but then I am a linux user and might be missing something.

Gimp installed in F: ? Have you tried renaming F:\Program Files\GIMP 2\var\cache\fontconfig to disable it. Guessing it contains hard links to non-existent files.

edit: That is strange, I do not seem to have a ..\Program Files\GIMP 2\var\ on my installation.
edit again: That reported as a bug https://gitlab.gnome.org/GNOME/gimp/issues/2574

yes... I've seen those less than wonderful fonts with awkward names, from time to time.

The Win Explorer view of Windows\Fonts shows the fonts rather than the font files, on my system. I get nothing when looking for *.otf, *.ttf – or just plain ttf, otf or ?tf, for that matter. And after trying that, I need to 'go out and come in again' because the screen won't show ANYTHING, search box empty or clear.  Put it down as a "It's Windows Explorer Search" issue – it's balky at the best of times.
Dropping to an admin-enabled console session shows the files present rather than the fonts installed, with a plain old DIR. It's just as confusing, because I can now see files that shouldn't be there. Blooming Windows.

Yup. F:\
put it down to 'historic reasons'

Program Files\GIMP 2\var\cache\fontconfig gets recreated on my system if its been renamed or deleted, when Gimp starts.
Contents don't show up as hard links.

Interesting bug – am I going to have to learn how to fudge the config?

PS I had a look at the files Gimp is referencing on startup.
It seems to be hitting C:\Windows\Fonts\StaticCache.dat file during its font search, which claims to have not been updated since 30th August 2019.

Then again, I've just had a look at it with various tools and its Last Access time is still the same 30/08/2019 time too, so who can say...
Reply
#8
Quote:Yup. F:\
put it down to 'historic reasons'

Program Files\GIMP 2\var\cache\fontconfig gets recreated on my system if its been renamed or deleted, when Gimp starts.
Contents don't show up as hard links.

Interesting bug – am I going to have to learn how to fudge the config?

You could ask on the Gimp user mailing list https://www.gimp.org/mail_lists.html

If you need something to try on your F: partition/drive then there is a portable Gimp https://samjcreations.blogspot.com/2019/...-bits.html Bit of a monster but might just avoid those old fonts.
Reply
#9
(02-10-2020, 01:49 PM)rich2005 Wrote: You could ask on the Gimp user mailing list https://www.gimp.org/mail_lists.html

If you need something to try on your F: partition/drive  then there is a portable Gimp  https://samjcreations.blogspot.com/2019/...-bits.html Bit of a monster but might just avoid those old fonts.

Right you are – thanks a lot for taking the time to check things out; if I find out what the solution is, I'll add the answer.
Reply
#10
The solution to the 'fonts won't leave' problem seems to have been that the font files were present on the C:\Windows\Fonts directory but Windows did not have them loaded.

How that happened is a little difficult to say – my leading (but untested) hypotheses are either:
  • The fonts were in use when uninstalled so, while the system definitions had been removed, the files were still in place
  • Windows has more than one font maintenance route (accessing C:Windows\Fonts via Windows Explorer / Settings>Fonts) and a disparity arose between them.
A test has shown that the existence of an 'unknown' font file in C:\Windows\Fonts can be brought about by the simple method of copying at the command line, but this didn't happen in this case.


HOWEVER.

While it is possible for Windows not to know of the existence of a file in the C:Windows\Fonts directory, it appears that Gimp's font acquisition system access some font files in C:Windows\Fonts and also interrogates the C:Windows\Fonts\StaticCache.dat at startup and WILL pick up the existence of files Windows doesn't know about, presenting them in the Gimp fonts list as normal.

Notes.
The underlying problem being investigated, that Gimp does not show all font names for some font families, substituting  
fontname
fontname #1
fontname #2
fontname #3
and presenting a system default font instead of the required glyphs for anything labelled with '#n', seems to be related to some form of non-unique identifier within the font files being presented to Gimp; if a single file, only, is loaded, it can be used correctly within Gimp, no matter what occurs when multiple files for the font family are loaded. As soon as multiple files are loaded, the only usable font appears to be the first one in the list lexically (I have not yet identified the sort field – see below).

There seems to be no difference in font behaviour whether the font files are presented via Windows or placed in a directory referenced from Gimp's Edit > Preferences > Folders > Fonts

Examination of the font files in Fontforge shows no obvious duplicated label in the fonts under test (a commercial OpenType edition of Farmhouse 1.0 and Farmhouse Rough 1.0) – it would have to be obvious because I am not a FontForge expert.

[EDIT]
With respect to the underlying problem stated above, the otf file has the FontForge 'TTF names' entry
String ID: Preferred Family
String: Farm House Rough
common to all the files in the font set.
This value is then picked up by Gimp and, as it is not unique, causes the additional fonts in the set to be unavailable.
Removal of the non-unique Preferred Family string allows the PS Names 'Family Name' string to be used which, in this font set IS unique.
Reply


Forum Jump: