Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
G'mic problems?
I've read in several other threads people make casual reference to experiencing problems with Gmic, and as someone who just started using it, I'm curious what "well known" problems people are experiencing? (so that if I notice the same problem, I won't suspect the cause is due to a problem specific to my installation).

One thing I've had  issues with is that about  every third or fourth time I use it, closing Gmic will freeze Gimp up tight, none of the menu items is accessible, and the only path forward is to force Gimp to end, without opportunity to save the work. Highly frustrating.
This is even after having the notorious "internet" box unchecked. And happens on machines where Gmic is the only  addition to Gimp, as well as machines that have beaucoup add ons.

Interestingly enough, I do not experience this problem using Gmic inside Krita, so I'm not at a hair pulling standstill, I'm just trying to understand what's going on between Gimp and Gimc.

Is this in any way similar to the problems others are experiencing?

One other oddity that I noticed last night.  using the "gradient from line" function in Gmic under Krita... when I told Gmic to save the resulting .ggr file, the end result WAS NOT saved in  /home/yourname/.local/share/krita/gradients/ as one might suspect to be the default location.  The file was in fact saved to  /home/yourname/.config/GIMP/2.10/gradients/

And I just found this unusual for the default "as installed" original configuration working inside Krita.

Which version of G'MIC do you have problem with? (Linux or windows?)
All version 2.x.x are phasing out (even though 2.9.9 is the latest stable, you will not have the latest bug fixes even if you update the filters)
Which linux is it this time. (I looked at a 'live' knoppiux usb and not a lot of joy with either gimp_gmic_qt or krita)

I never have any problems with Gimp in kubuntu and gimp_gmic_qt crashing. There can be problems when using an old version of gmic and updating. The gmic syntax often changes and can break some of the filters, particularly in the testing section. From a couple of weeks ago gmic version 3.0.0 includes the 'community' filters (aka update300.gmic file) in the code. Download, install and no need to update. (except of course you might have to update, to get a specific fix)

If using an older gmic version I recommend backing up the updatexxx.gmic file before running the update function. I have some old update files archived just in case.

The gmic gradient from line. You have more success than me getting this out of krita however it does look like the destination is 'hard-wired' Running this in my Gimp 2.10.22 appimage puts the ggr file in the regular Gimp user profile. No workaround.
(12-04-2021, 11:09 AM)rich2005 Wrote: Which linux is it this time. (I looked at a 'live' knoppiux usb and not a lot of joy with either gimp_gmic_qt or krita)

As always, ,,your efforts and feedback are sincerely appreciated. 

 knoppix 9.1  with Gimp 2.10.22  with Gmic 2.9.4  That particular gimp version is included in the knoppix 9.1 distro....and the gmic version was just obtained as the default offering from the bundled Synaptic package manager

Likewise knoppix 9.1 with Krita 4.4.8  also with Gmic 2.9.4

And then, just to make things interesting, I fired up my old Windows 7 machine last night, running gimp 2.10.18 and a version of gmic that is at least 2 years old (didn't think to write down the version)...just trying to duplicate the failure, and couldn't do it.  gmic performed flawlessly...every time out of about a dozen tests.

So, the "problem" appears to be confined to the gmic/gimp combination that I am running'

I suppose I could try updating my gimp version, but "everything else" seems to be working fine, so I have some apprehension jumping into a gimp update not knowing what unintended consequences might accompany sich a move.

At this point, it's a curiosity that grew as I was reading other threads here and noticed various members discussing their own problems with gmic, and immediate feedback from other members acknowledging that problems are "known"

So, this thread was intended  mostly to ferret-out what known malfunctions are in the knowledge base.

Once I encounter a problem such as this, I usually try to chart out a list of conditions that provoke the failure, vs not...and I've noticed that while using gmic 2.9.4, under gimp, under knoppix 9.1:

1). The problem never happens when using Krita as the host application, just when using Gimp as the host

2).Some of the time under  Gimp, the problem does not happen at all.  But when it does happen, it's only if Gmic is closed while Gimp remains open. When I elect to use the "apply" button in Gmic without hitting the "ok" button.....essentially sending the Gmic output to Gimp while sending Gmic to the background...the problem has not ever happened.

Which is great, the obvious solution is to say  "fine, don't close Gmic until you have finished your Gimp session, and let them both close together when you eventually close gimp,... except

3). Some functions of Gmic  auto terminate, sending the satisfactory  output to the Gimp canvas, but locking the Gimp up tight as a drum in the process.

4). I've noticed that even  when this problem happens, "last state" is preserved for Gmic  for that specific session (such as making the institutional logos appear or disappear, or ticking/unticking the internet check box)
However, "last state"  selections in Gimp for that session (tool in use, pattern in use, color in use) are NOT preserved, and will resort back to whatever was in use the previous time Gimp closed normally.

5). The problem can be reproduced on a machine  having no other additions to Gimp other than Gmic, as well as it can on a Gimp installation laden with GAP, FX Foundry,  Liquid Rescale,  and the retro "Python for Gimp" it's doubful that the problem is a reaction to Gimp add ons not playing well together

I'm a bit surprised that no one has jumped in saying they are familiar with the problem, considering exchanges by others I've read  here explaining their own experiences. with other issues.

But, I guess I should feel fortunate that I'm not at the end of my rope, since Gmic under Windows, and Gmic under Krita appear to be bullet proof, And 90% of the time I can avoid the problem under Gimp with a little operational discipline.

That other 10% though, remains a curiosity

Strictly as an aside, but I've really been enjoying the "gradient from line" function, which you recomended  in another thread. Being able to lift the profile of a structural I-beam from a picture, and then utilizing the gradient function to "draw" an fantastic!!

(12-04-2021, 01:33 AM)PixLab Wrote: Which version of G'MIC  do you have problem with? (Linux or windows?)
All version 2.x.x are phasing out (even though 2.9.9 is the latest stable, you will not have the latest bug fixes even if you update the filters)

I'm afraid that I'm not a very "apt-get" type of person, and that may be part of the problem.  Using the Synaptic package manager for updates, the only Gmic for Gimp offered is version 2.9.4  And I've seen you suggesting version 2.9.9 to others...I'm not even seeing that offered in the repositories polled by Synaptic  so My problem  likely has roots in that regard.

However, the same version of Gmic seems to be working for me under Krita, in the very same Linux distribution, as well as in a very old Windows the disfunction I'm experiencing  via Gimp/Knoppix has me scratching my head a bit.

And, just to belabor the point....suppose that I am using the"gradient from line" function of Gmic.   I trace the line, give it a name, and hit the "apply" button...everything is fine...gradient shows up in Gimp with a simple refresh.

But if I hit the "OK" button, Gmic exits normally, but frequently leaving Gimp completely unresponsive...requiring a forcible closure.

Oddly, if in the above scenario..... after naming the created gradient, suppose I just hit "OK" and not touch "Apply" at all.  The created gradient is satisfactorily saved to the default gimp/2.10/gradient folder, even though gimp will be locked up tight  after Gmic closes.
That suggests to me that Gmic  must be satisfactorily concluding it's mission, or the created file would not be saved?

For the record, I just did a sacrificial lamb update to gimp 2.10.28 on one system, and the problem persists.

Good news being that nothing bad or unexpected appears to have happened as a result of the gimp next time I do a global refresh, I'll make that upgrade permanent. So then, I guess that leaves the 2.9.4 version of the plugin as the primary suspect.

Going back to your original post and quote...this I've read in several other threads people make casual reference to experiencing problems with Gmic, and as someone who just started using it, I'm curious what "well known" problems people are experiencing?

A lot of the problems are just installation problems, Windows in particular now has an excellent gimp_gmic installer, always someone who uses the zip and get it wrong. Otherwise, often it is using an old version and updated filters not working, mostly those in the testing (community) section. 
Any other errors usually fixed very quickly when David Tschumperlé is informed. For that version 2.9.4 there are 398 filters rising to 566 with the testing section.

I have a feeling that the problem might just be the actual knoppix system.  It is 32 bit, and depending on your computer might leave memory a little tight.

You can start with the 64 bit kernel, Gimp is still 32 bit but you might get better performence. This a comparison and you get more cache and swap space.  Laptop with 8GB memory


That first one using a bit more memory, after installing the gimp_gmic_qt plugin That is one slow installation Wink
Much appreciated!!

Admittedly I'm just speculating, but it appears to me that G'mic is actually a "stand-alone" application, and the plug-in aspect is just a tie-in between G'mic and it's host applications? It looks to me to be that way, because changes made to the settings in G'mic under Gimp, persist into the next session of Krita, if I use both applications in the same computer session. Further reinforced by my recent experiences upgrading Gimp to version 2.10.28

I decided to do a completely fresh reinstall of my entire system, housekeeping that I'd just planned, yet had been putting off. And in the process managed to screw up G'mic pretty bad. in fact when under the newly installed version of Gimp, the newly installed G'mic would not even load...gimp giving me an error message each time I tried to use G'mic

What surprised me is that upon installing fresh the newly released update of Krita, complete with what Krita settings guide describes as "G'mic special version for Krita".... yet the G'mic would never load inside Krita. You could try to open it, and wait all day, it would never open....So, clearly whatever I did to hose G'mic during the Gimp install, managed to "pre-corrupt" the Krita install of it's access to G'mic. Couple that with the insistence of Gmic that it save gradients to a Gimp directory, even when operating from Krita, and the G'mic does appear to be a common beast of burden between both applications.

All better now, as I figured out what I was doing wrong, and re did it. But I did find it noteworthy that in the Krita settings guide it makes specific mention of potential incompatibilities of various file versions between Krita and Gimp.

Kudos as well to the Gimp team, for at least making their splash screen user configurable. I'm loathing being tied into the christmas tree themed splash the latest release of Krita features. And shocked that the lead developer is actually proud that their splash screen is hard-baked into the binary. Not that I am anti-holiday, I'm just thinking ahead to how long I'll be cozy with such a narrow focused splash screen?

(12-05-2021, 12:15 PM)rich2005 Wrote: I have a feeling that the problem might just be the actual knoppix system.  It is 32 bit, and depending on your computer might leave memory a little tight.

 Well,  just for closure...PROBLEM RESOLVED!! (just in case anyone reads these old threads)

And it wasn't shortage of memory, and it wasn't due to any "deficiency" of my 32 bit architecture  Wink

And it really wasn't a problem with gimp, although circumstances made it appear that way.

The solution that ended up working is when "gimp" is hung up after closing g'mic....merely opening up task manager and and finding a lingering g'mic zombie process, selecting the process and killing it. released gimp with the work process in tact.

And that was the real nature of the beast, if I was working on a drawing, and edited  with g'mic....sometimes when closing g'mic it appeared to cause gimp to freeze, no menu functionality at all, and the only path forward was to force gimp closed, losing any work in progress.

But, even though g'mic appeared to be closing normally, it wasn't.  In fact it was continuing to appear as an active process, along with a script-fu..   But, killing g'mic allows the script-fu to close also...AND FULL FUNCTIONALITY OF GIMP IS RESTORED.

No more lost work!!

After reading your earlier suggestions, I added 4 Gb of ram, and that didn't improve this specific problem,  so I started reproducing the problem with gimp opened in a terminal session, and observing reported conditions step by step...noticed a specific malloc error immediately upon creating the "hung" condition.

And of course what I know about programming you might be able to fill a thimble with, but upon googling the exact error message,...  pointed me a number of times to software development forums where the point of discussion was centering upon careless implementation of the qt innerface....usually something about failing to clear the memory properly upon program exit.

And since I was experiencing the exact problem upon exit of a qt based made enough sense to live with. As they say, the pieces seemed to fit.

Do I have any expectation that the developer might find and eventually fix the problem? I'm happy to say that really no longer problem with lost work has been solved, that's all that matters to me.  Big Grin


Forum Jump: