Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Gimp 2.10.16?
What is the current version?  On the main Gimp site it say 2.10.14.

Something weird is going on here . . . My version says 2.10.16.

I did not update it.  Now the histogram info works again, but the paintbrush can't draw in snapped angles like 45, 90, 135 . . . with the Control key down.

I don't remember running an update.


Nevermind.  Gimp 2.10.16 is coming out today.  I guess the only relevant thing is this post is that preset angles like 45,90,135 ... don't work anymore with the Control key down for the brushes.  2 steps forward and 1 step back, I guess
Is it a bug ? Maybe you can report it? Sort of works but maybe not the way you expect Wink

I put in a couple of guides as a reference point. This is from the end of one line up to the guides, 36.25 ⁰


Hold the ctrl key down, still on the guides but shows 30 ⁰


..and it does indeed draw the line at 30 ⁰

(02-20-2020, 02:00 PM)mholder Wrote:
(02-20-2020, 11:35 AM)rich2005 Wrote: Is it a bug ? Maybe you can report it? Sort of works but maybe not the way you expect Wink

I put in a couple of guides as a reference point. This is from the end of one line up to the guides, 36.25 ⁰

Hold the ctrl key down, still on the guides but shows 30 ⁰

..and it does indeed draw the line at 30 ⁰

Not on my version 2.10.16.  Is says it does at the bottom, but CONTROL does definitely not constrain the angles.

Also, it corrupts xcf files I save.  It looks like I am losing masks in layer groups.  Very sad.  I have no idea why GImp updated the flatpak.  I did not run the update from the terminal.

Amazing.  I wonder why in the world did this update?  Saving as psd files works, sort of.  At least it doesn't corrupt the image.

The problem with psd is that I have to go manually through each layer and set the linear blending mode.

It seems (not sure yet) that if I save with the compression option, then it won't corrupt the file.

Attached Files Thumbnail(s)
No, saving with the compression does not prevent the corruption.

I still don't understand why Gimp updated to 2.10.16.  It is obviously not ready.  I understand that software is not perfect, and sometimes there needs to be fixes.  But why in the world did this thing update!?

I mean should I just stop everything I am doing?  Am I going to automatically get a fix without updating again?  This is mind-blowing, and a good reason why almost nobody uses Gimp for any serious production work.  I mean, who can I complain to?  It is free.  Better off not using it and becoming dependent on it. 

I mean this should never happen: an update that went on without me knowing and it broke the software?  How is this any different from some commercial project that automatically updates?  Well, I will tell you the difference: I can call somebody and complain.

Actually, Blender does a much better job: just put an binary executable in a download, sort of like a appimage.  Actually, Blender doesn't even do that.  It is so much better of a system than this. 

So anyone that maybe can update to 2.10.16, DON'T DO IT!  Figure a way to keep it from updating.  It is not ready and will corrupt your files!
Do not blame Gimp for the update. If you are using one of the latest ubuntu's they have a horrible automatic unattended update that is a disgrace. More like MS Windows than linux, not easy to turn 100% off.

I gave up on the flatpak Gimp when I moved to (k)ubuntu 18.04 Too limiting for my use, so no hands on advice.

Try this one About half way down the page the section Downgrading.

As I recall there was a similar outcry when Gimp 2.10 was introduced, everyone wanting it to behave like Gimp 2.8 Wink
Ok I blame Linux Mint (sort of Ubuntu), but Gimp pushed the 2.10.16 that is not ready.  It isn't a little thing.

Not trying be over dramatic, but I am in a bit of trouble here, and it will cost me some serious time to get this figured out.

And honestly, comparing 2.8->2.10 is not really the same as complaining about 2.10.14->2.10.16

But anyway, thanks for the link, and I will see what it can do.

Still no clue what it causing the corruption, but it seems the new feature that extends past the boundaries when running filters (like noise->spread or long shadow) may be killing the layer group masks.  Also, I trying to stay in 16 bit float helps.  Again, psd files work, but everything reverts to sRGB gamma screwed-up blending.

OK it seems that whenever I save an xcf file that has off-canvas areas, then that is what is corrupting the file.  I can't say 100% certain, but it looks like it.  If I see any layers with the boundary beyond the canvas, then I need to resize it to the canvas size before saving.  I hope someone sees this and it helps.  I use Gimp almost every day, so I hope I am quick to notice some of these issues.  Also the brush tool does not snap to constraints with the CTRL key.


Attached Files Thumbnail(s)
So far, it seems the best way to avoid corrupting files is to always choose the 'Clip' option for some filters.

If you don't and save, then it will be corrupted.  This happens every time.  After I save it once, then if i resave it with the same name, the new save is also corrupted even if I resize the layer to image size.

Simply having oversized layers doesn't seem to be an issue, only when running GEGL filters that expand the layers beyond the canvas causes the issue, or so it seems from my tests.


Probably a simple mistake or oversight.  Other than that I really like the new 2.10.16 version.  And they fixed the histogram!

Attached Files Thumbnail(s)
To avoid automatic flatpak updates in Linux Mint: Go to your control center - then to the startup- programmes applet.
There you'll find a flatpak update item. Disable it and flatpak won't update automatically anymore.
(Worked for me as long a I had the flatpak stuff installed. Change to the PPA - and still use GIMP 2.10.12 because of al those bugs).

Awesome, thanks!  I didn't realize Flatpak updates were in the startup list.  Yes, that is stupid to automatically do, but generally speaking, this is the most broken Gimp update I've ever seen,
To judge from this comment on a new bug, the developers now know about the corrupt xcf issue:

Forum Jump: