Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Gimp not working after os update
I have used Gimp, version 2.8.0, on my desktop mac, OS 10.8 (mountain lion), for several years. Yesterday I updated my operating system to 10.12.5 and now Gimp doesn't work. I get a message saying, weirdly, that Gimp cannot open Gimp-format files. My X-Quartz is version 2.7.2

Has anyone any idea what the problem might be and how to remedy it?


I have now updated XQuartz to 2.7.11, but it hasn't made any difference.
Welcome to

Unfortunately not many (any) OSX users around here, but from previous posts you will need to update Gimp which is now at version 2.8.22

The stock version is at and it says there

Since the 2.8.2 version, GIMP runs on OSX natively. No X11 environment is required.
The official GIMP 2.8 DMG a stock GIMP build without any add-ons. It works on OS X 10.6 Snow Leopard and later. Just open the downloaded DMG and drag and drop GIMP into your "Applications" folder.

For a (McGimp) version that includes many additional scripts and plugins you could try a version from
That worked immediately. What a great welcome to gimp-forum! Thank you very much
I've just upgraded to High Sierra (10.13.1). The latest stable GIMP (2.8.22) will not load – it gets stuck looking for files.

Is there a solution?
Looking for which files? Fonts?
(11-09-2017, 02:21 PM)Ofnuts Wrote: Looking for which files? Fonts?

Any and all files during GIMP startup.
You mean it stops on a different file each time?
(11-09-2017, 03:35 PM)Ofnuts Wrote: You mean it stops on a different file each time?
Never mind. It works now. Apparently, High Sierra is soooooo bloody slow that it takes GIMP nearly 5 minutes to complete the loading process! WTF.

Warning: Do NOT upgrade to High Sierra!

Forum Jump: