Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Gradient issues with GIMP 2.10.4, fade to transparent
#1
Hi there,

I recently got GIMP 2.10.4 after previously using 2.8. When initially learning how to fade layers to transparent, I used a tutorial which I will post below. With the new version, I am doing the exact same steps. When I get to "drag a vertical line from the bottom of the image to where you want the fade effect," NOTHING happens. No gradient, nothing. I've tried this several times with the same failure. Did something change with the new version, or am I just completely missing something?

Add a Layer Mask
  1. Open up the Layers menu [CTRL][L]. If you're opening just a basic jpeg or png there should be just one layer at this point.
  2. In the Layers menu, right click on the layer and select Add Layer Mask.
  3. Make sure White (full opacity) is selected and click Add. You should see a white box show up next to the thumbnail of your image in the Layers menu.
Create the Fade Effect
  1. Right click on your layer and make sure that Edit Layer Mask is selected.
  2. Make sure that the Foreground Color is set to Black and the Background Color is set to White in the GIMP tools menu.
  3. Click on the Blend Tool (it should be just to the right of Bucket Fill).
  4. Drag a vertical line from the bottom of the image to where you want to stop the fade effect. (Hint: Hold down the [CTRL] key to help make the line vertical.)
Reply
#2
Hit the ENTER key to fix the gradient. The only other difference from Gimp 2.8 are the blending modes in the tool options. You probably want to be on LinearRGB (I think default is perceptualRGB)

[Image: 0IR9T97.jpg]
Reply
#3
When nothing happened with the gradient, I had the layer selected. Now I have unselected the layer and applied the gradient under Linear RGB. The gradient is applied behind the layer, but not on the layer itself. Image is attached, I hope.


Attached Files Thumbnail(s)
   
Reply
#4
Well I do not know what you are doing from that screenshot. The layout is a tad unconventional.

What it does show is the layer mask is not active, Look for a white border = active.
What ever you do with the gradient it will not show in the layer mask unless it is active.

[Image: 9lJO83A.jpg]
Reply
#5
I see what the problem is. I activated the layer mask like you said, and still nothing was happening. It turned out that the gradient blend mode was set to Lighten Only for some reason. I switched this back to Normal and it works just fine.

Thanks for your help
Reply
#6
I'm very new to Gimp and it took me 2 days to have this sorted. I was pulling my hair out thinking how silly am I not to be able to replace the exact instructions. Found this out today and I am so happy that I've finally made it work. I had a feeling the solution would be simple.
Reply


Forum Jump: