Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
How to get entry in "Open with"
I installed gimp appimage 2.10.21 in ubuntu 20.04 having extracted it following Rich's advice. Again thanks to Rich I am able to run it from the terminal and by clicking on its icon in activities.
The cherry on the cake would be if I could have it appear as an option in "Open with".

I have searched the net and the advice I have found suggests adding %U at the end of the Exec= line and adding the MIME types to the .desktop file which I got from Rich.

Both of these I have tried without success. Any ideas would be appreciated.

Have you rebooted or update the mime cache?

Here's an excerpt from here

Refreshing the MIME Database

Understanding how to refresh the MIME database is important for administrators who wish to add new MIME types to the system, or otherwise modify information about a MIME type. The application update-mime-database is intended for this purpose.
For example, if an application installs information about a new MIME type to /usr/share/mime/packages/diff.xml, then update-mime-database must be called with the parameter /usr/share/mime.
# update-mime-database /usr/share/mime
* Updating MIME database in /usr/share/mime...

The MIME database is refreshed by scanning all the source XML files in the directory <MIME>/packages.


Thanks for your reply.
I perhaps was not clear in what I wrote. The MIME Types are already in the database and are used by other programs.
Possibly the problem may relate to the fact that the Exec= line in the .desktop file ends in /AppRun, which is a file to initiate the gimp program.
I shall investigate further!

I can not say that I never use file associations but not-a-lot Wink

Try editing ~/.config/mimeapps.list adding entries as 


You might not need that x-xcf, a plain xcf might do. In this example (Mint 20 VM) there is a flatpack Gimp  which has xcf as an association.

Right click for the menu or a click-click on the icon works here. No guarantees though Wink


Thanks for the information - problem solved!

A peculiarity:- When I looked in the .desktop file it had the application type as "graphics" and the text editor highlighted it in red. After reading a few documents on the net, I changed this to "Application". Then right-clicking on image files (jpeg, tiff, etc.) I was able to find gimp under "open with".

However, this did not work for .xcf (no "open with" tab). Your solution was the fix.

Thanks again - a lifesaver as always!

Hi David,
Glad you got it all worked out!
(09-04-2020, 08:57 AM)david Wrote: I perhaps was not clear in what I wrote. The MIME Types are already in the database and are used by other programs.

You were perfectly clear, but I did misread it as adding the mime types to the DB and not the desktop file.

Forum Jump: