Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
"Layers" dock stuck at top left of screen
I am brand new to GIMP and to this type of editing software generally.  I was doing a YouTube tutorial which was showing how to move the dockable dialog boxes around and I tried to move the layers box onto the desktop and it seems to go straight to the top left corner, covering even the red, green and yellow screen resizing buttons. 

I searched for a solution on the internet and found one from about year ago, saying it was a bug.  Im wondering if its a bug why it hasn't been fixed.  

I am running GIMP on MACOs Mojave.  

In the tutorial the layers box can simply be moved onto the desktop, no problem, but on my computer if I try to move any of the docks onto the desktop I end up with this problem.  

Has anyone else had this issue and if so is there a way to fix it so I can move my docks? Thank you in advance.
This was the subject of a bug report but from memory not resolved.  Bearing in mind that I am a die-hard linux user and there might be better ways.

This problem seems to occur when the tool options tab / or some other tab is accidentally dragged into the canvas (1) Which gives that 'Tool Options' / other tab hiding part of the Gimp menu. (2)


Right click on the little Tool Options left arrow and close the Tool Options Tab (3)

Now Restore the Tool Options to one of the other docks (4)


Click and Drag that Tool Options tab back into the You can drop dockable dialogues here area (5)

Which should get things back to normal. Stop a re-occurrence, Lock the Tool Options Tab in place. (6)


Same procedure for any of the other docks you might have moved. Close then open again and lock in place.

I did not really answer your question about the layers dock and maybe moving any of the docks around. You do have to be accurate with the destination but it does work. The little top left icon is only temporary.
However I suggest using the menus. Close the tab in one dock and add in another dock.

Thank you for this. Sorry I didn't see this response before now.

Forum Jump: