Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
NLFilter not found (greyed out)
#1
Hi all,

GIMP 2.8.16

I couldn't find NLFilter

-> Filters -> Enhance

NL Filter is NOT there.

Please help.  Thanks

Regards
SL
Reply
#2
From your earlier posts you are using Ubuntu 16.04 - Is that still correct?

The filter is there in my (k)ubuntu 16.04 Gimp 2.8.22. 
It is a compiled plugin. Can you check in /usr/lib/gimp/2.0/plug-ins that the file nl-filter is there and it is executable.

   
Reply
#3
(03-16-2019, 05:41 PM)rich2005 Wrote: From your earlier posts you are using Ubuntu 16.04 - Is that still correct?

The filter is there in my (k)ubuntu 16.04 Gimp 2.8.22. 
It is a compiled plugin. Can you check in /usr/lib/gimp/2.0/plug-ins that the file nl-filter is there and it is executable.
Hi,

Thanks for your advice

Filters -> Enhence -> NL Filter
It is there but grey-out, not working.

⟫ ls /usr/lib/gimp/2.0/plug-ins/ | grep nl
Code:
nl-filter
It is there.

⟫ ls -al /usr/lib/gimp/2.0/plug-ins/nl-filter
Code:
-rwxr-xr-x 1 root root 23264 Jul  1  2016 /usr/lib/gimp/2.0/plug-ins/nl-filter

⟫ ls /usr/lib/gimp/
Code:
2.0

But I'm running GIMP 2.8.16


Regards
SL
Reply
#4
The filter works only on images without Alpha channel.
Just remove it and you weill see it active.
Reply
#5
(Yesterday, 04:56 AM)dinasset Wrote: The filter works only on images without Alpha channel.
Just remove it and you weill see it active.
Performed following steps;

⟫ cd /usr/lib/gimp/2.0/plug-ins/
⟫ sudo mv nl-filter nl-filter.old
⟫ ls | grep nl_*
Code:
nl-filter.old

NL_Filter still grey-out even after rebooting PC

Regards
SL
Reply
#6
Read the previous post again. 

It is the image alpha-channel that is the problem. Do not remove / disable the filter. Remove the image alpha channel Layer -> Transparency -> Remove Alpha Channel

   
Reply
#7
(Yesterday, 09:35 AM)rich2005 Wrote: Read the previous post again. 

It is the image alpha-channel that is the problem. Do not remove / disable the filter. Remove the image alpha channel Layer -> Transparency -> Remove Alpha Channel
Hi,

I got it after removeing "Alpha Channel"

Thanks

Regards
SL
Reply


Forum Jump: