Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
No heal transparency in GIMP 2.10
I have GIMP 2.10 installed from the Ubuntu Cosmic repository. I also have installed the gimp-plugin-registry package, and I can see under /usr/lib/gimp/2.0/plug-ins a file.

However, I cannot see the "Heal transparency" filter in the menu. Also, in the plugin filter I don't see any plugin whose name contains "Heal", but "Resynthesize" is there in the list.

I have also tried to install the flatpak version from, but the filter does not appear there either.

Any advice of what could I try to get the filter to show? I would happily downgrade to 2.8, but package repositories that also include the gimp-plugin-registry seem to be all on 2.10.
Check the pluginrc file in your Gimp profile. You should fin the resynthesize file listed, but do you see the *heal*.py files?

If they are missing, a few possibilities:
  1. they are missing the "execute" flag
  2. they don't run correctly
  3. they don't run at all
1) is not too likely (and easy to check)

Since you run a very recent Ubuntu 2) and 3) are possible, because Ubuntu has been in the process of making Python v3 the default Python.

2) would be because the script are run with Python v3 instead of the Python V2 they have been written for (Gimp mandates v2).

3) would be because there is no Python v2 installed on your system.

Start Gimp in a terminal (gimp --verbose), and this will show you everything Gimp is doing on startup. Have you got python syntax error reported then? Or is it complaining about a missing Python2.7 executable? Have you go a file named /usr/lib/gimp/2.0/interpreters/pygimp.interp? It will contain lines such as:


Do the left parts (/usr/bin/python2.7) match an executable in your system?

By the way, you can tell if the problem is for resynthesize only or if it is a general problem with Python. There are standard scripts/plugins that use Python, and they won't show in the menus if the Python support doesn't work:: Filters>Web>Slice, Filters>Decor>Fog and of course Filters>Python-fu>Console.
Thanks for your thorough response.

When running gimp --verbose, I get the following error:

Quote:Failed to execute child process “python” (No such file or directory)

However, I have both python 2.7 and 3.6 in my system. If I execute "python" in a terminal, I get into an interpreter console.

Quote:ls -ltr /usr/bin/python*
-rwxr-xr-x 1 root root     314 Jan 19  2017 /usr/bin/python-argcomplete-tcsh
-rwxr-xr-x 1 root root     314 Jul 20  2017 /usr/bin/python-argcomplete-tcsh3
-rwxr-xr-x 1 root root    2555 Jul 20  2017 /usr/bin/python-argcomplete-check-easy-install-script3
-rwxr-xr-x 1 root root    2554 Jul 20  2017 /usr/bin/python-argcomplete-check-easy-install-script
lrwxrwxrwx 1 root root       9 Jun  7 17:57 /usr/bin/python2 -> python2.7
lrwxrwxrwx 1 root root       7 Jun  7 17:57 /usr/bin/python -> python2
lrwxrwxrwx 1 root root      10 Jun 27 17:18 /usr/bin/python3m -> python3.6m
lrwxrwxrwx 1 root root       9 Jun 27 17:18 /usr/bin/python3 -> python3.6
-rwxr-xr-x 1 root root     152 Sep 20 10:50 /usr/bin/python3-pbr
-rwxr-xr-x 2 root root 4865504 Sep 27 10:41 /usr/bin/python3.7m
-rwxr-xr-x 2 root root 4865504 Sep 27 10:41 /usr/bin/python3.7
-rwxr-xr-x 2 root root 4534936 Sep 27 10:51 /usr/bin/python3.6m
-rwxr-xr-x 2 root root 4534936 Sep 27 10:51 /usr/bin/python3.6
-rwxr-xr-x 1 root root    5902 Oct  1 09:54 /usr/bin/python3-wsdump
-rwxr-xr-x 1 root root 3690840 Oct  2 23:12 /usr/bin/python2.7

So, it is possible that my system is trying to run the plugin with the wrong version of Python?

There is no /usr/lib/gimp/2.0/interpreters/pygimp.interp in my system. I tried creating one with the content:


And now instead I get the following error on startup for a number of plugins:

Quote:Querying plug-in: '/usr/lib/gimp/2.0/plug-ins/'
Traceback (most recent call last):
 File "/usr/lib/gimp/2.0/plug-ins/", line 28, in <module>
   from gimpfu import *
ImportError: No module named gimpfu
gimp: LibGimpBase-WARNING: gimp: gimp_wire_read(): error
Terminating plug-in: '/usr/lib/gimp/2.0/plug-ins/'
The full contents of my /usr/lib/gimp/2.0/interpreters/pygimp.interp is:


But before you break everything, did you check that other Python plugins are also broken?
Quote:..I have GIMP 2.10 installed from the Ubuntu Cosmic repository..

That should ring a few alarm bells Wink

Does not matter if python 2.7 is installed , there is no python support in Gimp 2.10.6 from the repo.

[Image: MuohUwp.jpg]

It gets worse, trying alternatives
The otto-kesselgulasch/gimp ppa has un-met dependencies so that is no use
The otto-kesselgulasch/gimp-edge ppa does install, but guess what, Gimp has no python support.

Wasted half the afternoon on all of that,
FWIW my advice, never mind cutting edge, ubuntu 18.04 has Gimp 2.8.22 as standard and you can either replace with Gimp 2.10 from a ppa or run the flatpak in parallel.
Hate to be beat Wink

A little bit of digging, a couple of tools that Ubuntu should provide but don't (synaptic and a two pane file manager emelfm2)

Python is missing because the gimp-python package is not set as a dependency, you have to install yourself. Used to be like that in the past, but not recently. screenshot: I used synaptic but I suppose a
sudo apt install gimp-python
will work.

Don’t use the gimp-plugin-registry package, apart from being full of ancient cr*p, liable not to work

Use these plugins, resynthesizer, I compiled against Gimp 2.10 packages

Unzip. The four files go in ~/.config/GIMP/2.10/plug-ins Looks like this

Does it work, does here:
That's it! gimp-python is not present in the Ubuntu repository, but I installed the one from and it works now Smile
I've just switched to Ubuntu (18,04 LTS) from Windows (not out of choice but because I messed my system up with some dual-boot shenanigans..!!) so this post is very helpful! Thanks all!

Forum Jump: