Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
NormalMap.exe Application Unable to Start
Windows 10 (1803) build 17134.112 64 bit
Gimp 2.10.4 (and Gimp 2.10.2 - but I upgraded) 

I'm getting an error as Gimp runs it's PlugIn Scan on Startup where it tells me: normalmap.exe - Application Error "The application was unable to start correctly (0xc000007b). Click OK to close the application."

This started when I tried to actually use NormalMap.exe from the Filters | Map drop down. I haven't used it since I was using Gimp 2.8 - where it did work.

I downloaded the normalmap.exe package again - gimp-normalmap-win64-1.2.3
I installed that per the readme.txt copying the dll files to the bin directory and normalmap.exe to the plug-ins - and overwrote the versions already there.

I still get the error about normalmap.exe being unable to start. So I found instructions to build a normal map manually and took care of that project.

But now everytime I start Gimp, I still get that error. I've tried uninstalling Gimp entirely. Deleting the directories in my C:\Program Files\ folder and the AppData folders. Eventually I even scrubbed gimp from the registry. But everytime I reinstall Gimp the Normal map error comes back - even though I don't even want to reinstall it. I also scrubbed all the references to NormalMap that I can find. I also removed the GTK directories.

Somewhere the system wants to find normalmap.exe and run it. But it doesn't run on my setup, so I want to remove it. And there I'm stuck and need help.
I found part of the problem. Windows doesn't show .xxxxx folders or files in normal searches. So I missed that gimp-2.8 had left behind a .gimp-2.8 folder. I cleared that out and now NormalMap.exe isn't trying to run. Now, though, I'm missing my libenchant.dll file. I will have to find where that can be acquired now.
Are you using the 64 bit normalmap plugin from samj? Consists of four files
glew32.dll, libgdkglext-win32-1.0-0.dll, libgtkglext-win32-1.0-0.dll, normalmap.exe - yes that is for 64 bit.

Not a plugin I use but a quick try in a Win10 (VM) & Gimp 2.10.4 (just installed) - I put the lot in the plugins folder C:\Users\your-name\AppData\Roaming\GIMP\2.10\plug-ins and it seems to work. screenshot:

The readme that comes with the zip says put normalmap.exe in the user plug-ins folder and the other 3 in C:\Program Files\GIMP 2\bin which I think is a bad idea.

One of the issues with installing Gimp 2.10 over a previous Gimp, especially Gimp 2.8.x is;

1. Old files remaining, Gimp 2.10 uninstalls Gimp 2.8 but not any user installed "extras"
2. Transfer of resources, scripts, plugins, brushes & some settings from the 2.8 profile /.gimp-2.8 Not always guaranteed to work.

I would look in your Gimp 2.10 folders for old files, might find them by date. Might be easier to purge all the Gimp installation, disable the Gimp 2.8 profile and re-install a clean installation. No good looking in the Windows registry, very little goes in there apart from un-install info.
The solution was easy for this second issue - though it took me a lot of time trying to figure out where I would find a libenchant.dll. Finally I thought "I didn't have trouble while I was in 2.10.2" so I reinstalled that after uninstalling 2.10.4 yet again. I tested it really quick, just launching 2.10.2 and not finding anything missing. Then I installed 2.10.4 over that. And now no alerts that libenchant.dll is missing. And clearing out the hidden 2.8 configuration removed the trouble I was having with the phantom normalmap.exe trying to invoke during the plug-ins scan.

And since I forgot to add it to the preview self-reply - I found the .gimp-2.8 (I'm sure there was more to the name that I can no longer remember) using the MS-DOS Command Line Directory command: dir *GIMP* /s /b - and there it was. Using the Windows Explorer search feature missed that, even though I have "Show Hidden" enabled. So ... the command line is still useful.

I don't know if it is just on my setup or if 2.10.4 is missing something in the install (or maybe I chose the wrong options on the installer...). But I'm back to a fully functional Gimp installation.
That libenchant.dll file seems to be causing some problems
I'm getting a forum error that I've selected more than one post to quote, and I don't see the quote in my reply box to cut and past just what I want. So replying to Rich2005...

Yes, I believe I had the 64 bit version - the zip file is gimp-normalmap-win64-1.2.3

I think a setting from 2.8 was confusing the install, so I might be able to install it now that 2.10.4 is running well again. I did a fresh "clean" install of 2.10.2 which got rid of errors that popped up after clearing out the 2.8 config information. I think NormalMap may have been trying to find the dll's in the 2.8 install, which no longer existed. Clearing out the old ~/.gimp-2.8 completely got me on the right path. I only had a few "extras" installed in 2.8 - Most of what I do the default tools work well for. If I find I need them again I'll download the latest versions.

Thank you, Rich, your information is good and anyone else with a similar trouble will be smart to follow your advice.

(07-06-2018, 08:15 AM)rich2005 Wrote: That libenchant.dll file seems to be causing some problems

OK, I figured out the quote thing... lol - my brain isn't as fast on the uptake as it once, theoretically, was.

I haven't registered at the gitlab portal. We might suggest trying a clean install of 2.10.2 and then 2.10.4 over top of that.
Yes.  This is a problem with a 'clean' installation of Gimp 2.10.4 in Windows.

A comparison of the Gimp 2/bin folders 2.10.2 contains libenchant.dll while 2.10.4 contains libenchant-2.dll
Installing 2.10.4 over 2.10.2 provides the file.
If you have a trusted source you can add the file libenchant.dll yourself.

More than a good bet that there will be a new Windows Gimp 2.10.4 installer before long Wink

Forum Jump: