Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Pattern export problem
I'm trying to save or export a pattern in GIMP 2.10 in Windows 10. I opened Folders in Preferences and set C:\Program Files\GIMP 2\share\gimp\2.0\patterns as my writable patterns folder. Then I went through the drill of using Filters > Map > Tile Seamless to prepare my image. Finally I tried Save As, navigating to my patterns folder, naming the file Pink1.pat, and clicking to save. That resulted in an error message directing me to the Export function. That resulted in the attached error message.

Since that didn't work, I went back and selected the other available option,
C:\Users\slipp\AppData\Roaming\GIMP\2.10\patterns, as my writable folder. This time I went directly to Export As, but got no further than C:\Users\slipp. At that point, I found no AppData option, only a .gimp-2.8 folder.

I was able to export as pink1.pat into that folder, but then had to copy and paste into the C:\Program Files\GIMP 2\... folder to access it from within GIMP.

That worked, but seems like a bug. Why doesn't GIMP let me export directly into the folder I need to use?

Attached Files Image(s)
C:\Users\slipp\AppData\Roaming\GIMP\2.10\patterns is the correct place to Export your patterns.

In Windows Explorer, do
File > Change folder and search options > View
and check "Show hidden files, folders and drives"

Does this solve the probkem?
Quote:..Why doesn't GIMP let me export directly into the folder I need to use?

To protect you from breaking Gimp ;Wink

First thing: The place for any resource, patterns brush, scripts, fonts, is for a standard installation the Gimp user profile:


Appdata is a hidden folder, in Windows see:

A legacy from Gimps linux origin is the Gimp installations folders are marked as non-writeable. You can enable the C:\Program files... entry but as far as I know Gimp will not write to it, you can use Windows explorer but the best place is still your Gimp profile.


Gimp can use png and jpeg files as patterns so it is not always necessary to export as a Gimp .pat file. Put them in the patterns folder.


When exporting as a .pat there is a Gimp setting (again from linux) Right click in the Export dialogue gives a Show Hidden files option. A hidden file is anything starting with a dot. You might/might not need that.
Ok all of that to export


Remember to refresh the patterns or they will not be available until the next time you start Gimp.

BINGO! Thanks Blighty and Rich2005. Rich, you nailed it. I had to right-click to get access. I exported as both .jpg and .pat (with a new name). Problem solved. So happy it's easy to make patterns now. That Tile Seamless filter is amazing. I may yet become a GIMP master. :-)

BTW, changing the folder view to show hidden files is one of the first things I do on a new computer, so I had no idea that this did not carry through to all apps.

Glad to know the other file formats work, since I already have a slew of patterns from Photoshop and Corel that are .png or .jpg. I'm relieved that I don't have to convert them.

Forum Jump: