Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Pictures won't show in Gimp
I have Gimp 2.8.16 and when I open pictures the files show and sub-files show but when I click the files, there are no pictures there. If I select "show all files" then they show but when I try to load, Gimp doesn't recognize the file name whether GIF, JPeg, etc. Also if I draw something in Gimp there are no extensions to select from to save. Also noticed when I went to "About Gimp" the link to Gimps web page doesn't work. Not sure what went wrong but I do know the last thing I did that could have changed things was when I did a disc clean up. I'm running Window 10 - 64 bit. I've read a lot of old complaints about similar issues but nothing worked or the person helping talked over my head. Not all that savvy with computer operations. Any help or ideas I would love. Thanks
The file type - load / save functions are Gimp plugins.

The first thing to check is the path to the Gimp system plugins. In Edit -> Preferences -> Folders -> Plug-ins is there a path 
C:\Program Files\GIMP 2\lib\gimp\2.0\plug-ins ?  Even if it is there click the Reset then OK and restart Gimp. See if that makes any difference.


A bit more drastic, rename your Gimp User profile C:\Users\"yourname"\.gimp-2.8\ folder as a backup. Start Gimp to make a new default and see if files open / save.  Move any resources from the backup to the new profile.


Very rarely needed but if something in Windows has crippled Gimp and you need new install. 
Choose your preference  for an installer.
Thanks for responding. Appreciate it. I can only get to Edit -> Preferences -> Folders . There is nothing that says plug-ins.  Even though I couldn't get to plug ins I did a reset and restarted and still no plugins.  I did a Gimp reinstall back when I first noticed the problem in early 2022. I didn't try any of your other suggestions yet in case not seeing plug-ins makes a difference in what I should do next. Again, thanks for trying to help.
(11-20-2023, 04:37 PM)Tumbleweed Wrote: I can only get to Edit -> Preferences -> Folders . There is nothing that says plug-ins. ...snip...

If you look at the first screenshot I posted, there is a small plus/minus icon next to the folders name. That expands into all the Gimp path folders.
Now I feel really stupid but yes I do have plug-ins by expanding folders like you said.  The first line has the exact path you have in your example. The second line is this:
C:\Program Files\GIMP 2\GIMP 2\lib\gimp\2.0\plug-ins
I did a reset, restarted Gimp and that didn't help. Tried highlighting the second line and resetting and restarting Gimp and still no pictures showing. No time to mess with this today but I might try the other suggestions you made when I have some spare time. I really appreciate you helping me. You are a gem!
Well, that "first line" should have your user_name in it (not exactly the same as my example)
This one C:\Program Files\GIMP 2\GIMP 2\lib\gimp\2.0\plug-ins seems to have an extra \GIMP 2\ from what I consider normal, is that a typo ?

Certainly try the next de-bugging step. Rename your user profile C:\Users\"yourname"\.gimp-2.8 to C:\Users\"yourname"\.gimp-2.8-backup Then restart Gimp to make a new default user profile and see if you can open an image.

Forum Jump: