Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Plug-in Resynthesizer not Found (Big Sur)
#1
I'm new to GIMP and have read that the resynthesizer plug-in is an easier way of removing an object from a photo while maintaining the background so I tried to download it. I'm using an M1 Macbook Air running GIMP v2.10.22 and I've followed each step from Davies Media Design Tutorial (https://www.youtube.com/watch?v=MiE-buxZij4&t=287s). However when I try to use the plug-in (Filters>Enhance>Heal Selection), a dialog box always appears saying this:

An error occurred running python_fu_heal_selection
error: procedure not found
More Information:
Traceback (most recent call last):
File "/Applications/GIMP-2.10.app/Contents/Resources/lib/gimp/2.0/python/gimpfu.py", line 740, in response
dialog.res = run_script(params)
File "/Applications/GIMP-2.10.app/Contents/Resources/lib/gimp/2.0/python/gimpfu.py", line 361, in run_script
return apply(function, params)
File "/Applications/GIMP-2.10.app/Contents/Resources/lib/gimp/2.0/plug-ins/plugin-heal-selection.py", line 148, in heal_selection
pdb.plug_in_resynthesizer(timg, tdrawable, 0,0, useBorder, work_drawable.ID, -1, -1, 0.0, 0.117, 16, 500)
error: procedure not found
Any help would be appreciated!
Reply
#2
It might be the plugin is incompatible with your macOS / Gimp 2.10.22 versions. There are reports about intrusive mac security issues see: https://github.com/aferrero2707/gimp-plu...ion/issues

Otherwise, are you sure the plugin files resynthesize & resynthesize_gui are set as executable. Looks like this in an old mac VM and old Gimp 2.10 (and works there)

   
Reply
#3
I had the same issue, and it came down to the resynthesizer plugin not being able to start, as it was missing a required dynamic library: libintl.9.dylib 

The instructions I found at https://www.mattpopovich.com/posts/how-t...-mac-2021/ was useful for getting it all working.
Reply


Forum Jump: