Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Pointer size issue
#1
I just made the switch to Linux and I'm using POP OS with GIMP 2.10.

My cursors are normal sized when using the OS. But, when I open GIMP, the cursor size is massive.
Is there a way to change the cursor size to match the OS cursor size?
I searched through the menus and couldn't see any way to do it.
I tried a couple of things I thought might do it, but had no luck.
Gimp is almost unusable with the super-large cursors.

Thank you for any assistance.

Dave
Reply
#2
Can you post a screenshot of Gimp and the cursor ? Is it the actual tool cursor - each tool has its own cursor icon Edit -> Preferences -> Image Windows has a Mouse Pointers section.
or Is it something like a brush outline, large brush = large outline? or The cursor you get outside the canvas, a pointer. (I think you already covered that, just checking)

Are you using a graphics tablet ?

----------

Well pop_os is closely tied to System 76. Did you buy one of their computers or install yourself ? If from System 76 maybe they can give some advice otherwise pop_os seems lacking in user support. There is a sub-reddit https://www.reddit.com/r/pop_os/ might get some advice there.

However, pop_os is based on ubuntu (and gnome DE) I use kubuntu 20.04 and have never come across a large cursor issue. Does your computer have a 4K display ? It should not make a difference but might.

The only setting I can think of at the moment is Gimp theme. Try Edit -> Preferences -> Interface -> Theme and select 'System' might / might not make a difference to the cursor. Otherwise, a trawl through the gnome system settings might turn up something, I can change cursor size here in KDE easily.

If nobody comes up with a solution / nothing works, do post the problem for the developers https://gitlab.gnome.org/GNOME/gimp/-/issues it might be something that can be fixed.

Edit: A quick search: 4K problems go back a couple of years, no fix https://gitlab.gnome.org/GNOME/gimp/-/issues/3742
but there might be one here: https://askubuntu.com/questions/972113/h...4k-display
or https://www.reddit.com/r/pop_os/comments...s_scaling/
Reply
#3
Computer is a Minisforum HX90.

I can't paste the screenshot. But it is the pointer that is very large.
I'm using a 40" TV as the monitor(1080p), so 4K shouldn't be an issue.
No graphics tablet, just a mouse/keyboard.
The pointer is normal size on the desktop and other applications.

I posted an image to my Instagram, I hope that helps.
Thanks for responding!!

https://www.instagram.com/p/Ce_7SM-JRoG/..._copy_link
Reply
#4
I have never seen that before, but it looks like it is the TV. Someone else with a similar problem
https://forums.linuxmint.com/viewtopic.php?t=355280 big cursor on TV (but ok on regular monitor) Although the desktop environment (DE) seems to have an effect.
pop_os uses gnome you could see if you can install some other DE
or
Use a 'live' usb to boot and see if there is any difference. You could try the knoppix iso KDE , has Gimp installed and runs on just about anything. Not for a permanent installation, just a try-and-see.

I have tried a few possibilities here, Changing the Gimp resolution setting / Changing the computer screen size / Changing the system cursor size. To no avail.
Guessing it is that HDMI connection to the TV rather than a Gimp issue.

I do not know, maybe someone will come up with a solution

Edit: Just been looking at the Minisforum HX90 specs (very nice) . It has 'display' ports and HDMI connections. I assume HDMI is being used. Any settings in the bios for these ?
Reply
#5
(06-19-2022, 08:43 PM)rich2005 Wrote: I have never seen that before, but it looks like it is the TV. Someone else with a similar problem
https://forums.linuxmint.com/viewtopic.php?t=355280  big cursor on TV (but ok on regular monitor) Although the desktop environment (DE) seems to have an effect.
pop_os uses gnome you could see if you can install some other DE
or
Use a 'live' usb to boot and see if there is any difference. You could try the knoppix iso KDE , has Gimp installed and runs on just about anything. Not for a permanent installation, just a try-and-see.

I have tried a few possibilities here, Changing the Gimp resolution setting / Changing the computer screen size / Changing the system cursor size. To no avail.
Guessing it is that HDMI connection to the TV rather than a Gimp issue.

I do not know, maybe someone will come up with a solution

Edit: Just been looking at the Minisforum HX90 specs (very nice) . It has 'display' ports and HDMI connections. I assume HDMI is being used. Any settings in the bios for these ?

That's what is weird. The pointer is normal size in every other program and I had no issues when running windows and Gimp.
If it were throughout the OS, I could understand it, but it only happens in Gimp.
I just confirmed that even Inkscape has normal sized pointers.
It seems to be limited to Gimp only. Very Weird!!

Yes, using HDMI for the monitors
Maybe it is an issue with running dual monitors.
I'll disconnect the second monitor tomorrow and see if that helps.

Thanks,
Dave
Reply


Forum Jump: