Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Removing fonts from Linux GIMP
#1
Greetings, folks--
Does anyone have an idea on how to get rid of the extra fonts (for other alphabets, etc.) from GIMP in Linux Mint (Cinnamon)?  I have Fonts Manager and those fonts disabled but they still show up in GIMP.  Thanks in advance for any help!
Reply
#2
On KDE, (Ubuntu 19.10) disabling the fonts in the font manager works...
Reply
#3
Thanks, Ofnuts...
I am using Cinnamon instead of KDE, and I do have the font manager but no dice disabling them there.  Now that I think about it, I had to add Font Manager myself and I do not know if it is doing anything!
Reply
#4
You could try the attached font-manager .deb (remember to un-zip it ) This is not the same as the fontmanager.app from the repo. A double click should start the package installer and pull in any missing dependencies. Take no notice of '..a newer version is available .. messages.   see screenshot https://i.imgur.com/8qlskVw.jpg

In use: Once the fonts are scanned, Choose system and go down the list un-ticking the ones to disable.  When you close font-manager log out and log back in to make effective.   A list in Gimp rendered and much-much reduced.  screenshot: https://i.imgur.com/GxU6jSa.jpg

Works here, no guarantees.

Edit: Actually, you can get it if you enable this 'buntu PPA (and there is an update)
https://launchpad.net/~font-manager/+arc...tu/staging


Attached Files
.zip   font-manager_0.7.3-1+b1_amd64.deb.zip (Size: 288.51 KB / Downloads: 2)
Reply
#5
Thanks, Rich2005--
That is actually the font manager that I am using. No luck. Thanks though!

Edit: I added the PPA just to make sure. I do have the most recent version. although the website says that there is a .7.7 version. I have the .7.3 version.
Reply
#6
(05-19-2020, 07:11 PM)petedecember Wrote: Thanks, Rich2005--
That is actually the font manager that I am using.  No luck.  Thanks though!

Technically the font manager application is mostly managing files in /etc/fonts/.
Reply
#7
Strange how things vary. Those screenshots do come from a LM 17.1 admittedly not updated for some time and MATE DE I would not have thought that a Cinnamon version would be much different.

Have a look in  ~/.config/fontconfig/conf.d/  for the file 78-Reject.conf  file generated by Font-Manager. I will attach the one from that LM 17 installation for comparison, it might show some difference.


Attached Files
.zip   78-Reject.conf.zip (Size: 2.1 KB / Downloads: 2)
Reply
#8
Thanks for your help, guys--
I looked into /etc/fonts. Yep, they are there, but I don't feel comfortable just blitzing some of them to see what happens. Part of that is because of the 78-Reject.conf file. Mine has more characters but fewer lines. I glanced through it and everything seemed to be the same. My guess is that the difference is all of the different fonts with longer names. They must have switched a lot of fonts between 17.1 and 19.1. Thanks again for the help. Let me know if anything else comes to mind, please!
Reply
#9
Font-manager should work, Is the current installation the result of successive upgrades from LM 19.1 to LN 19.3 ? It could just be that font-manager is stuck. Try moving the 78-Reject.conf out of its folder as a backup. That restores font manager to all fonts active. Let font-manager make a new conf file.

Those earlier screenshots were LM 19.1 (not 17.1 my typo) MATE version. I have a lot of dev packages installed in that, so a brand new LM 19.03 Cinnamon install (VM)

Gimp 2.10.14 from PPA lists these fonts. https://i.imgur.com/h40jdpT.jpg

Font-manager gets very slow when it comes to the Noto families of fonts. Something about those fonts. https://i.imgur.com/icbLed5.jpg
I un-ticked in two stages up to Noto - a log-out & back in then down the noto and the remainder.

FWIW that gave a much reduced Gimp font list: https://i.imgur.com/NIWxUSO.jpg

Otherwise, don't know. Something in your installation un-disabling the fonts Wink
Reply
#10
ARGH! Update Manager just "had a broken packet," and now my Font Manager is gone! Update Manager did say something about a broken packet, but when I used the Broken Filter in packet manager it said that there weren't any broken packages. I am just about to remove my 78-Reject.conf file and do a reboot...

EDIT: After removing the 78-Reject.conf file and rebooting, the fonts are still all in GIMP and the Font Manager is still missing. I will reinstall font manager and will post any changes.

EDIT: Thanks for the suggestions rich2005! Smile

Thank-you again for the idea, rich2005: I reinstalled Font Manager and this time it worked. I was even able to figure out what fonts I wanted to disable by watching the font list in GIMP and hitting the font refresh button after I had gotten rid of some. The only problem now is that the font on my Chrome Browser is tiny.... ARGH!!
Reply


Forum Jump: