Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Script-fu error on selecting font
#1
I am getting error messages from script-fu. 

For example, I opened File-->Create-->Fx-Foundry-->Logos-->Fiery Steel.  When I select the Font box to change the Font I get the following message.


Quote:GIMP Message

Plug-in "script-fu"
(usr/lib/gimp/2.0/plug-ins/script-fu/script-fu)
attempted to install procedure "temp-procedure-
number-1" with invalid parameter name "dialog status".

                                                               OK

The font can not be changed.
Any suggestions on how to correct this problem?
I am using GIMP 2.10.8 on Ubuntu Studio 20.04.  Any other info needed?

Allan
Reply
#2
Best guess Wink you installed the gimp-plugin-registry package from the ubuntu repo. 20 plugins and 164 scripts, most of which do not work with Gimp 2.10 I do wish that package was removed.  My advice for this is uninstall it, it is junk.

xtns-lankinen-fiery-steel.scm is for at best Gimp 2.8 The syntax changed with Gimp 2.10 for example ADDITION becomes LAYER-MODE-ADDITION-LEGACY  I will attach a fixed version for Gimp 2.10 if you want to try it. Unzip and put in  ~/.config/GIMP/2.10/scripts/  (only that one, fix the others yourself)

Back to your initial problem. You really are using Gimp 2.10.8 ? You should update it. There was a bug round about Gimp 2.10.8 / 2.10.10 where the font selector was broken. In linux, you can get round that by clicking and dragging from the fonts dock into the script dialogue box. example:  https://i.imgur.com/qemnzZw.jpg

There are still problems with that old script and older versions of Gimp. The script uses a bump-map and that was not applied in earlier version of Gimp 2.10. Seems to fixed now. This a comparison, 
https://i.imgur.com/CYwEyf6.jpg The original script in Gimp 2.8 / the fixed up script in Gimp 2.10.14 / the fixed up script in Gimp 2.10.22. You can see the 2.10.14 is 'flat'The developers finally got backward compatibility for bump map.

Edit: If you want some scripts that have been successfully updated for Gimp 2.10 some here: https://www.gimphelp.org/script210.html At least you can browse and view examples.


Attached Files
.zip   xtns-lankinen-fiery-steel.zip (Size: 4.23 KB / Downloads: 11)
Reply
#3
rich2005,

I doff my hat and bow.  Indeed I was using said gimp-repository, in spite of warnings I had read that the plug-ins were outdated (this inconvenient fact I conveniently forgot).

Certainly one way to remove the problem is, well, to simply remove the problem. ;)  Amazingly, removing the outdated repository, removed the problem script and hence the problem.  But excuse the weak attempt at humor.

I used your script successfully, but I needed to perform the font drag and drop to choose the desired font.  In addition I had also had to do a gradient drag and drop.  Choosing he font or gradient from the script window resulted in the error above.

Lastly, correction on the GIMP version.  I am using GIMP 2.10.18

I appreciate your assistance!

Allan
Reply


Forum Jump: