Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Stylizing GtkNotebook Tabs in Theme (gtkrc)
I think I have found something!!!

Almost every defined style in the gtkrc file, ends with the following line:
  #engine "clearlooks"  { }

I think this might be the issue on Linux. Try deleting the # sign from ALL occurrences of those lines.

Put otherwise, Replace every:
  #engine "clearlooks"  { }
  engine "clearlooks"  { }

I have a feeling this might fix the issue. On Windows it is enough for the clearlooks engine to be defined in the default style, but maybe on Linux it should be specified inside every defined style. Actually I checked again my older themes, and they have that line enabled in all defined styles.

Most text editors provide a Search & Replace function, so you do not have to do it manually for every line.

Please let me know if that fixed the issue.
@migf1 Bingo!

All good now. Thanks!
Yeah! Thank you very much!

Maybe the line:
engine "clearlooks" { }

should also be added to defined styles that do not have it too (not sure).
v1.2.1 is now up guys:

Thank you very much for all your help!

Forum Jump: