Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
I have 2.10 with windows 10. I have a problem with the text not showing up on the screen when I log in to Gimp. The text across the top, (File, Edit, etc) is fine, but when you click on one of these the block comes up but there are only small squares showing, no text. Any suggestions?

Attached Files Thumbnail(s)
This is a Windows system issue and can be difficult to resolve.

Is the computer set up with multiple languages?

You can try changing the Gimp language but some of the process will be by touch-n-feel Wink

Go to the Gimp menu Edit and bottom of the menu is Preferences screenshot:

That brings up a whole list of options and you want Interface which is probably in little squares.
Look for the third down from Tool Options. Click on that then click on the section under Language


That gets a drop down menu with lots of language options, choose English then guess where ok is (bottom right icon) Ok all and restart Gimp.

If that does not work. Uninstall Gimp from the Windows uninstall menu.
Delete anything C:\Program Files\Gimp (if remaining)
Delete the Gimp profile C:\Users\your-name\AppData\Roaming\GIMP\2.10\ (this is a hidden folder, you need to enable hidden folders)

Install Gimp again using the Customize option which gives a language choice.

If that does not work try an alternative from
Looks like the theme is using a font which isn't there (or badly installed). Tried to swith to another theme?

Forum Jump: