Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Trouble with addonCollectionManager
#1
I am unable to use addonCollectionManager with the configuration file in the attached zip, under:
- GIMP 2.10.22 installed from scratch
- Windows 10 installed from scratch, too.
I have tried, with different results:
1. Both addonCollectionManager-3.0.py and addonCollectionManager.ini in personal plug-ins folder, in other disk--same parent folder as my {type} and {type}_storage folders. 
Result: dialogues created as expected in Gimp, but Scrollbox is empty. 
Report in addonCollectionManager(1).log (attached zip).
2. Both addonCollectionManager-3.0.py and addonCollectionManager.ini in C:\Users\{user's_id}\AppData\Roaming\GIMP\2.10\plug-ins. Result nil in Gimp, report in addonCollectionManager(2).log (attached zip).
The trouble appears to be a path mixup, as reflected in the logs...


Attached Files
.zip   addonCollectionManagerReport.zip (Size: 2.23 KB / Downloads: 51)
Reply
#2
Make sure you have not duplicated the plugin / ini files. I am sure you looked at this, check http://gimp-tools.sourceforge.net/managementtools.shtml  Your attachments did not come through, however A quick test in Win10 /Gimp 2..10.22 to make sure.  You probably need to delete the pluginrc file as noted below.

Screenshot 01

   

In the Gimp User profile, the additional folder for the resources 'something'_storage these go alongside the regular folders.
Once everything is set up then also in the Gimp User profile is the file pluginrc delete that, start Gimp, the new settings are scanned, new pluginrc is created.

Screenshot 02

   

Right side:This is the attached addonCollectionManager.ini file to try out. It goes in the plug-ins folder with all the other plugins and the addonCollectionManager.py plugin.
Left side, what goes in the folders.
For brushes, patterns etc zip the files types  in collection zips although .abr brushes can be just zipped.
For scripts, you could put several scripts in a single zip but it makes more sense for each script zipped so they can be loaded and unloaded as required.
For fonts. Fonts are a bit strange in Windows. Do not zip the fonts, put similar types in folders. They usually load ok but Windows has a habit of not letting them to unload, sometimes until Windows is restarted.

Example ini file attached, Download, unzip it. Should show in the main Gimp window as a drop down menu.


Attached Files
.zip   CollectionManager-ini.zip (Size: 547 bytes / Downloads: 27)
Reply
#3
(12-01-2020, 09:10 PM)rich2005 Wrote: Make sure you have not duplicated the plugin / ini files. I am sure you looked at this, check http://gimp-tools.sourceforge.net/managementtools.shtml  Your attachments did not come through, however A quick test in Win10 /Gimp 2..10.22 to make sure.  You probably need to delete the pluginrc file as noted below...

Thanks, Rich! I have added the attachment--2 steps, and forgot the 2nd...
However, I made sure that the pluigins were fully reloaded at each try, and pluginrc never reported an error on loading the pluguin.
The trouble is exactly as reported--can be checked on the logs. My paths seem to be read for the check on the {type}_stored folders existence, but then, unexisting folders on the default path are linked...
Reply
#4
New day, new start. I see your attachment now

A couple of questions.
Are you using regular Gimp 2.10.22 from gimp.org ?
If so, was the installation a default into C:\Program Files\GIMP 2 or somewhere else ?
Does your user name cfier as shown in the log have any accented characters ?

Asking because your ini file from the zip uses a 'hard encoded' path instead of the Gimp variable {GimpUser}
Code:
enable:brushes dynamics fonts gradients palettes patterns scripts
addons_active:E:\GimpResources\{type}
addons_stored:E:\GimpResources\{type}_storage

and from the log the plugin is looking in a regular user profile which might be thrown off by accented characters.
Code:
No such file or directory: 'C:\\Users\\cfier\\AppData\\Roaming\\GIMP\\2.10\\plug-ins\\addonCollectionManager.ini'
Reply
#5
The first lines of the log say:
Code:
Configuration initialized OK
Reading configuration file C:\Users\cfier\AppData\Roaming\GIMP\2.10\plug-ins\addonCollectionManager.ini
Configuration file C:\Users\cfier\AppData\Roaming\GIMP\2.10\plug-ins\addonCollectionManager.ini not found or not readable: [Errno 2] No such file or directory: 'C:\\Users\\cfier\\AppData\\Roaming\\GIMP\\2.10\\plug-ins\\addonCollectionManager.ini'


As long as you have this the configuration file you create is not seen and aCM continues with the default configuration.

Can you open a terminal  (cmd.exe) and enter:

Code:
dir C:\Users\cfier\AppData\Roaming\GIMP\2.10\plug-ins\addonCollectionManager.ini

and see if it lists the file or reports an error?
Reply
#6
(12-02-2020, 09:24 AM)Ofnuts Wrote: The first lines of the log say:
Code:
Configuration initialized OK
Reading configuration file C:\Users\cfier\AppData\Roaming\GIMP\2.10\plug-ins\addonCollectionManager.ini
Configuration file C:\Users\cfier\AppData\Roaming\GIMP\2.10\plug-ins\addonCollectionManager.ini not found or not readable: [Errno 2] No such file or directory: 'C:\\Users\\cfier\\AppData\\Roaming\\GIMP\\2.10\\plug-ins\\addonCollectionManager.ini'


As long as you have this the configuration file you create is not seen and aCM continues with the default configuration.

Can you open a terminal  (cmd.exe) and enter:

Code:
dir C:\Users\cfier\AppData\Roaming\GIMP\2.10\plug-ins\addonCollectionManager.ini

and see if it lists the file or reports an error?
Hello! 
As to point 1, the trouble IMHO is in the unescaped '\': attached logs with escaped '\\' and linux-style '/' in the .ini file. No errors--neither dialogs in Gimp!

Point 2: no trouble!

IMHO: needed a way to tell plugin to search for {type}_storage in parent directory...


Attached Files
.zip   logs.zip (Size: 49.41 KB / Downloads: 23)
Reply
#7
Still wondering about that E: drive location and your original ini file (see that earlier post)

Code:
Configuration initialized OK
Reading configuration file C:\Users\cfier\AppData\Roaming\GIMP\2.10\plug-ins\addonCollectionManager.ini
Configuration file C:\Users\cfier\AppData\Roaming\GIMP\2.10\plug-ins\addonCollectionManager.ini read successfully
Creating manager for brushes
Searching directories as E:/GimpResources/brushes_storage/* for brushes
0 directories as E:/GimpResources/brushes_storage/* for brushes
Manager of brushes created OK: active: E:/GimpResources/brushes, stored: E:/GimpResources/brushes_storage, subdir: False, link: False, extensions: (u'.gbr', u'.vbr', u'.gih', u'.abr', u'.GBR', u'.VBR', u'.GIH')
Reply
#8
(12-02-2020, 10:11 AM)carmen Wrote: Hello! 
As to point 1, the trouble IMHO is in the unescaped '\': attached logs with escaped '\\' and linux-style '/' in the .ini file. No errors--neither dialogs in Gimp!

Point 2: no trouble!

IMHO: needed a way to tell plugin to search for {type}_storage in parent directory...

I'm lost. In you original log, you can't read the config file at all:

Quote:Configuration file C:\Users\cfier\AppData\Roaming\GIMP\2.10\plug-ins\addonCollectionManager.ini not found or not readable: [Errno 2] No such file or directory: 'C:\\Users\\cfier\\AppData\\Roaming\\GIMP\\2.10\\plug-ins\\addonCollectionManager.ini'

In you new log, the configuration file can be read:
Quote:Configuration file C:\Users\cfier\AppData\Roaming\GIMP\2.10\plug-ins\addonCollectionManager.ini read successfully

Escaping backslashes is only necessary in source code (string literals). But here the python code read the file names exactly as they are in the config file and does not consider the backslashes as special.
Reply
#9
(12-02-2020, 11:07 AM)rich2005 Wrote: Still wondering about that E: drive location and your original ini file (see that earlier post)

Code:
Configuration initialized OK
Reading configuration file C:\Users\cfier\AppData\Roaming\GIMP\2.10\plug-ins\addonCollectionManager.ini
Configuration file C:\Users\cfier\AppData\Roaming\GIMP\2.10\plug-ins\addonCollectionManager.ini read successfully
Creating manager for brushes
Searching directories as E:/GimpResources/brushes_storage/* for brushes
0 directories as E:/GimpResources/brushes_storage/* for brushes
Manager of brushes created OK: active: E:/GimpResources/brushes, stored: E:/GimpResources/brushes_storage, subdir: False, link: False, extensions: (u'.gbr', u'.vbr', u'.gih', u'.abr', u'.GBR', u'.VBR', u'.GIH')
Well--Windows creates its own default folders, appended to \Users. But I avoid them like the plague. Why? Because Windows keeps trying to control them--by giving them its own default configuration, syncronizing to drive (can create havoc with the Calibre library, for instance), etc. You change that today, and as likely as not, some update will undo your customization. Thus, having another partitioned hard disk available (used a partition before adding an SSD), I created a GimpResources folder in one of them, redirected Gimp there for add-ons (after setting the securty permits accordingly), and thus I am sure of controlling everything that goes on there. Besides having shorter paths and not risking losing them on reinstalling windows--C: formatted, other drives (physical or virtual) untouched, as long as they do not contain Windos-controlled folders. Of course, I do manual backups too...
Is a personal choice--but it has worked fine for me for years. With a single drawback: reinstalling windows can change the drive letter--must keep on my toes to update any path affected, as in that configuration file--updated and changed according to the last version of the documentation...
Reply
#10
Quote: default folders, appended to \Users. But I avoid them like the plague....

I suspected someting like that. (your are talking to the (linux) converted where I have much installed and running from a storage partition).
AFAIK unless you use a portable Gimp you will get a C:\Users\"yourname"\AppData\Roaming\GIMP\2.10\ set of files and folders. What does Edit -> Preferences -> Folders show Did you maybe delete the default path(s)

The plugin just copies then deletes to that location.

With Gimp 2.10.22 installed on a Drive F: I can get it working with (just the beginning of the ini file) and the files stored in sub-folders (xxx_resource) under a main folder F:\resource\

Code:
#-------------------------------------------------------------------------
[all]
# enable:brushes dynamics fonts gradients palettes patterns scripts
enable:brushes fonts patterns scripts
addons_active:{GimpUser}/{type}
addons_stored:F:/resource/{type}_storage
menu_location:{<type>}
menu_entry:{type} sets...
menu_description:Manage {type} sets...
dialog_title:{type} sets manager
[brushes]
menu_location:<Image>/Resource
extensions:.gbr  .vbr  .gih  .abr  .GBR  .VBR  .GIH

Ofnuts might have some solution, possibly starting Gimp from a batch file where new Gimp environmental variables are set.
Reply


Forum Jump: