Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Trouble with addonCollectionManager
#11
(12-02-2020, 12:13 PM)rich2005 Wrote:
Quote:  default folders, appended to \Users. But I avoid them like the plague....

I suspected someting like that. (your are talking to the (linux) converted where I have much installed and running from a storage partition).
AFAIK unless you use a portable Gimp you will get a C:\Users\"yourname"\AppData\Roaming\GIMP\2.10\ set of files and folders. What does Edit -> Preferences -> Folders show Did you maybe delete the default path(s)

The plugin just copies then deletes to that location.

With Gimp 2.10.22 installed on a Drive F: I can get it working with (just the beginning of the ini file) and the files stored in sub-folders (xxx_resource) under a main folder  F:\resource\

Code:
#-------------------------------------------------------------------------
[all]
# enable:brushes dynamics fonts gradients palettes patterns scripts
enable:brushes fonts patterns scripts
addons_active:{GimpUser}/{type}
addons_stored:F:/resource/{type}_storage
menu_location:{<type>}
menu_entry:{type} sets...
menu_description:Manage {type} sets...
dialog_title:{type} sets manager
[brushes]
menu_location:<Image>/Resource
extensions:.gbr  .vbr  .gih  .abr  .GBR  .VBR  .GIH

Ofnuts might have some solution, possibly starting Gimp from a batch file where new Gimp environmental variables are set.

You just need to set the environment variable GIMP2_DIRECTORY to point to the directory that should hold your profile. Can be done in a .BAT, but you can also set that variable system-wide, so that all Gimp invokations see it. If you use a .BAT you have to assign it as the opening application for several file types, while the environment variable technique will work with your current file associations.
Reply
#12
(12-02-2020, 12:13 PM)rich2005 Wrote:
Quote:... You just need to set the environment variable GIMP2_DIRECTORY to point to the directory that should hold your profile. Can be done in a .BAT, but you can also set that variable system-wide, so that all Gimp invokations see it. If you use a .BAT you have to assign it as the opening application for several file types, while the environment variable technique will work with your current file associations.
Thanks! Plugin now working--though I had to migrate the configuration files. Tanks again.
New: my elation, premature. Plugin worked on first run--but
Big Trouble: Gimp took control of E:\GimpResources, and all {type}_storage folders containig subdirectories got deleted--contents of subdirectories moved to {type}. So, undoing changes.
Reply
#13
New data: no environment variable, no errors logged--plugin reports 'Manager of {type} created OK', after identifying the correct folders, but... no manager in Gimp. See the attachment for configuration file, plugin and Gimp logs...
Help would be appreciated. Thanks!


Attached Files
.zip   addonCollectionManager_rep.zip (Size: 49.17 KB / Downloads: 34)
Reply
#14
You are still hard encoding the paths, and I am not sure that is the way to go, but it is up to you. 
Why no menu entry showing ? you have not added a location in the .ini file. Goes after each section heading.

Code:
addons_active:E:/GimpResources/{type}
addons_stored:E:/GimpResources/{type}_storage
menu_location:{<type>}
menu_entry:{Type} sets...
menu_description:Manage {type} sets...
dialog_title:{Type} sets manager
use_subdirectory:yes
use_link:no

[brushes]
menu_location:<Image>/XXXXXX
extensions:.gbr .vbr .gih .abr .GBR .VBR .GIH
[dynamics]
menu_location:<Image>/XXXXXX
extensions:.gdyn .GDYN
[fonts]
menu_location:<Image>/XXXXXX
extensions:.ttf .otf .TTF .OTF
use_subdirectory:yes
........etc.......

What works here.

Gimp installed on drive F as F:\GIMP 2 First run creates a regular Gimp user Profile in C:\Users\"yourname"\AppData\Roaming\...  screenshot: https://filedn.com/lkb9dw6mEfXSsOu9uKLaM...manage.jpg

I can make a simple Windows bat file to set the path to a new user profile, say F:\GIMP_PRO (use any sensible name you want)  This 1) sets the Gimp environmental variable GIMP2_DIRECTORY and 2) starts Gimp. First run same as a regular installation, Gimp makes the GIMP_PRO folder and populates with the default files and folders.  screenshot: https://filedn.com/lkb9dw6mEfXSsOu9uKLaM...manage.jpg

Code:
set GIMP2_DIRECTORY=F:/GIMP_PRO
start F:/"GIMP 2"/bin/gimp-2.10.exe

Now I can add the storage folders to F:\GIMP_PRO The files addonCollectionManager-3.0.py addonCollectionManager.ini go in F:\GIMP_PRO \plug-ins Delete the file pluginrc  so new settings are created. screenshot https://filedn.com/lkb9dw6mEfXSsOu9uKLaM...manage.jpg

...and that works for me. Using zipped files except for fonts which go in folders.  screenshot: https://filedn.com/lkb9dw6mEfXSsOu9uKLaM...manage.jpg
Reply
#15
(12-02-2020, 08:42 PM)carmen Wrote: New data: no environment variable, no errors logged--plugin reports 'Manager of {type} created OK', after identifying the correct folders, but... no manager in Gimp. See the attachment for configuration file, plugin and Gimp logs...
Help would be appreciated. Thanks!

Menu location should be <{Type}>, not {<Type>} (braces inside the brackets)
Reply
#16
(12-03-2020, 11:15 AM)rich2005 Wrote: ...I can make a simple Windows bat file to set the path to a new user profile, say F:\GIMP_PRO (use any sensible name you want)...
Thanks! This works--for lauchs from the .bat file. Only, I had to edit that file file to

Code:
echo
set GIMP2_DIRECTORY=E:/GimpResources
start /D "C:\Program Files\GIMP 2\bin\" gimp-2.10.exe
Can you have active something like 'Linux syntax extensions' (don't know exact name)?
Good tips for the config file too...

(12-03-2020, 01:38 PM)Ofnuts Wrote:
(12-02-2020, 08:42 PM)carmen Wrote: New data: no environment variable, no errors logged--plugin reports 'Manager of {type} created OK', after identifying the correct folders, but... no manager in Gimp. See the attachment for configuration file, plugin and Gimp logs...
Help would be appreciated. Thanks!

Menu location should be <{Type}>, not {<Type>} (braces inside the brackets)
Thanks! Typo corrected--and everything working.
Note: hard-coded paths like E:/GimpResources/{type}... and config in {user}/plug_ins seem necessary to put the add-ons in non-default folder--even the one containing the plugin...
Reply
#17
I have only been using the addonCollectionManager with gradients, patterns and brushes.

Today after downloading a little more than 20 fonts I decided to manage them via this application.

I created a folder fonts_storage and added the new fonts in .ZIP format - Everything seemed to be ok until I noticed that it was not possible to deactivate (remove) these fonts after use.

I also noticed that these fonts are copied into the Preferences\fonts folder, and only by deleting these copies manually in this folder I can remove the fonts from the Gimp. (Gimp needs to be closed for this to happen)

Searching around, I found Rich2005's tip:
(12-01-2020, 09:10 PM)rich2005 Wrote: For fonts. Fonts are a bit strange in Windows. Do not zip the fonts, put similar types in folders. They usually load ok but Windows has a habit of not letting them to unload, sometimes until Windows is restarted.
Then I changed all the .ZIPs into folders , putting each group of fonts that was in a .ZIP in the same folder.

It didn't work. 

This behavior only happens with fonts, with gradients, brushes and patterns the Addon can add and remove them perfectly.
[Image: g226qhu.png]

Could this be a Windows related case? 
Does anyone have/had the same problem?
Is it a known problem and is there already a simple solution?

Thx
Reply
#18
Could this be a Windows related case?  - YES
Does anyone have/had the same problem? - PROBABLY
Is it a known problem and is there already a simple solution? - YES (known) and NO (there is no simple solution)

Go into your fonts folder, delete anything that is stuck. Go into the fonts_storage folder and delete the .active file which keeps track of which font collection is active. Try again.

   

Both folders and zips will work, the real problem is Windows releasing the fonts when the user deselects them. Sometimes they go , often they remain until Windows is restarted.
Tried to get an all-in-one screenshot where,
(1) is the fonts_storage folder in your Gimp user profile
(2) contents of a zip
(3) contents of a folder
(4) Those two added to the fonts folder from (5)

Working here. As your query deactivating is the problem. the manager sticks because the Windows system 'holds' the font. In this example deactivating the zip did nothing. The folder is better, almost got there but a single font got stuck. Usually corrects next time you use Windows. 

Font manager works perfectly in linux, it is a Windows 'thing'
Reply
#19
Rich2005,
While this information isn't the best of the news, I'm still glad I'm on the "normal" side of things. (My gimp and my AddonCM are ok).

I just need to get into the habit of
Quote:"Go into your fonts folder, delete anything that is stuck. Go into the fonts_storage folder and delete the .active file which keeps track of which font collection is active."
 after each logout with the fonts or before closing the gimp.

Thank you very much!
Reply


Forum Jump: