Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
help is opening in a TEXT EDITOR
#1
How does gimp choose the app for viewing help? I do not have webkit, so I need an external browser. Even though I set the default app for text/html, text/xml, and application/xml to kfmclient (konqueror), gimp help always open in a TEXT EDITOR, which is the stupidest thing it could do.

I checked that
xdg-open /usr/share/gimp/2.0/help/en/index.html
does indeed open in konqueror, as desired.

The only thing that works so far is to uninstall the text editor, which again is the stupidest thing to do.
Reply
#2
I have used various linux KDE distros since 2004 (Mepis - PClinuxOS - now Kubuntu 16.04) and for most of the time Gimp F1 help, either local or on-line has not worked.

Just tried all sorts settings, nothing seems to work for me. Different browser (firefox), changing system settings..etc.

Having said that just tried a xubuntu 16.04 VM with firefox as the webbrowser and that works fine. Must be a KDE thing.

For that reason I do not even bother having help installed and use a PDF version from http://gimp.linux.it/www/meta/
Searchable and with an index, a good off-line alternative.

Since you find xdg-open /usr/share/gimp/2.0/help/en/index.html works, an option is make that into a shortcut. You would have to start help separately but at least that would allow you to keep your text-editor Wink

Out of curiosity. Which KDE linux are you using?
Reply
#3
I use Kubuntu 16.04 and the help works (remote version in Firefox). I assume Gimp uses whatever is defined to open HTML files in GTK.
Reply
#4
Looking at my very basic Kubunto 16.04 virtual machine + stock Gimp 2.8.16 + help installed from the repo.

With local help enabled in Gimp I get a
"Calling error for procedure plug-in-web-browser No application is registered as handling this file"

If I enable on-line help I get a message ending
"Perhaps you are missing GIO backends and need to install GVFS?"

Installing gvfs and gvfs-backends (pulls in a raft of dependencies) does get the on-line help working. (I recall that this never worked in my PClinuxOS instalation)

Strangely also gets the local copy working as well. Maybe that will fix the OP's problem

[Image: dPrHZvw.jpg]

Still prefer the PDF version.
Reply
#5
Gvfs requires a lot of gnome stuff, including some daemons, so no thanks.

I am compiling webkit now, so that gimp can have its own help browser. I was hoping for a simpler solution. THis has been compiling for hours.

To answer the question, the DE is Trinity (KDE3).
Reply
#6
oops, hit the post button too many times
Reply


Forum Jump: