Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
how to PERMANENTLY disable "recently used"
What it says!

I have turned up a 2015 thread on emptying the recently used list; but it fills up again.
I'd like the program not to keep that list at all.  Also seems the list on the side of the working screen and the list that is a category under "open" in the "file" drop-down are separate things, programmatically.

AFAIK, there are indeed two things:

  1. The Gimp history: things that appear in File > Open recent with the full list in File > Open recent > History
  2. The system history (may appear as "Recent files" in file dialogs) which is shared across applications (so, for instance, you can export a file in Gimp and find it very quickly to upload it with your browser).
I think the second can be disabled with Preferences > System resources > Document History > Keep record of used files in Recent Documents list.
In linux I run a script that deletes everything in .thumbnails / cache/.thumbnails and a file called recently-used.xbel  Gimp still Open's at 'Recently Used' but it is empty. It does fill up until I run the script again.

In Windows it looks like the file is C:\Users\"yourname"\AppData\Local\recently-used.xbel

You can try deleting it and check the effect in Gimp -> Open.  The file is re-created when you close Gimp and you get recently used files back.  It is remarkably persistent, making it read-only in file properties is not enough. In linux I have in the past made it "immutable". I just tried in a Win 10, even changing the security settings and the 'cursed' OS changes them back. So no permanent solution there

(edit: although worth a try. I have added a screenshot of an recently-used.xbel with no entries and the file security settings. I had a re-visit and it might work. )


At the moment, make a delete recently-used.xbel batch script is a possible although temporary plan.

Forum Jump: