Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
icons for drop-down menus
Hello. I'm using both 2.10 (appimage) and 2.99 (installed) on Ubuntu 18.04. Adwaita (default) Themes > Applications and Themes > Icons.  Being on gimp-edge ppa, I was automatically upgraded to 2.99 a couple of weeks ago.   Two issues: 

1 - my scanners have disappeared from File > Create.  This is not important to me; I only discovered that facility a little while ago.  Before that, and now, I scan first outside Gimp and then just open the saved scan.  Still, it would be nice... 

2 - I see no icons next to the words on the drop-down menus.  I've installed 2.10 under Windows / VMware, just to compare, and the icons are there.  I'm thinking of icons such as File > New,  File > Print, ...  There seems to be room for them, but nothing shows.  I think these did appear in 2.8, but I'm not sure.
Does anyone know if they 'should' appear?

[Gimp Theme is 'System' and Gimp Icon Theme is 'Color' - I did have to find and copy a full set of Icon Themes from 2.10, as only Legacy and Symbol were complete in 2.99]

These questions are more about my peace of mind than anything else.

Any ideas?
I'm slightly confused by what you're reporting.

Are you saying that both 2.10.? the 2.99 snapshot both have menu icons missing?

As "2.99" is a rolling development version, there is an expectation that it will be broken from time to time.

I've a recollection that in discussions with one of the developers, he was unaware that there were menu icons as his operating system/window manager didn't display them, so maybe check your system settings?
Thanks for your reply. Yes, same behaviour with both 2.10 and 2.99. Maybe there just shouldn't be menu icons (although there are in the Windows version). Let's see if anyone else has a comment. I have tried a number of system settings. Maybe I should get a life. The software's doing what I want it for just fine without the icons.
Scanners: It could be that the regular xsane packages are not compatible with gimp-edge, also not all that surprised if they do not work with the aferrero appimage, they do not here.

Trying Gimp 2.10 out in a Kubuntu 18.04 VM (and now a desktop) As Kevin commented about development versions, I found gimp-edge ppa very flakey (no python when I tried it).

The regular ppa:otto-kesselgulasch/gimp has Gimp 2.10.6 and works ok.

looks like this: 'hover-over' in system theme is 'off' but that is a kubuntu thing.

There was a recent post on the trials and tribulations of moving from one version to another.

You will also now have several Gimp profiles, ~/.config/GIMP/2.9 ~/.config/GIMP/2.99 as well ~/.config/GIMP-Appimage/2.10 Worth a tidy up in case any old settings have been carried over. Edit: Do you still have a ~/.gimp-2.8? Maybe settings carried over when the new version(s) make their profile(s)

Forum Jump: