Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ubuntu xenial and flatpak
Quote:...Got it working--I had put the files in the 'lib' directory for the application, instead of the runtime.

Thanks for that report, for reference the Gimp files are held in


Maybe the extra files will go when the Gimp flatpak updates (perhaps 2.10.2), which I think might be sooner rather than later. You might have to slip them in again. Not a big problem.

I do not know how often the org.gnome.Platform runtime updates, if ever, it will be nice if it does.

A list of flatpak commands
So far it's up and running. Thanks Rich for all those lib- files
BIMP complained about missing

found it in /lib/x86_64-linux-gnu as a link to
Copied that link  to /var/lib/flatpak/runtime/org.gnome.Platform/x86_64/3.28/some-long-string/files/lib
(Don't know how to do it the right way)
BIMP works now.

Still have some complaints from GIMP :

Failed to load module "gtk-vector-screenshot"
Missing fast-path babl conversion detected, Implementing missing babl fast paths
accelerates GEGL, GIMP and other software using babl, warnings are printed on
first occurance of formats used where a conversion has to be synthesized
programmatically by babl based on format description

That module is installed in my system, so I wonder what it really misses and how to solve that.

System info:
DESCRIPTION="Linux Mint 18.3 Sylvia"
GIMP 2.10.0
Ah..a Mint installation Thanks for the information.

Yes, never got round to adding to the zip of files. Done that now and included the BIMP plugin and nufraw as a separate zip. Nufraw should only be be used if you need it. It will disable loading SVG files, do not know why, in the code somewhere.

Most of those warnings have been there all through the Gimp 2.9.x development versions. Still there.

I do not know about that Failed to load module "gtk-vector-screenshot"

The screenshot File -> Create -> ScreenShot never worked for me in Gimp 2.9.x but there even better in Gimp 2.10 - amazing.

a couple of screenshots - the screenshot dialogue and the screenshot as an image

Ignore most of those warnings in the screenshots, I use an ancient theme and I always disable recently-used.xbel Hate that long list of filenames. The flatpak keeps the recently-used.xbel file in ~/.var/app/org.gimp.GIMP/data/ so you can always delete it when required. Also a ever increasing folder of image thumbnails - delete as well.

If you are able to make a launcher in Mint Mate, then you do not see all those messages Wink
With the Installation it created the launcher in the Mint Menue.
Also it created system integration ... so when I now click on "open with GIMP" it's Gimp 2.10 which opens, not 2.8.

I launched it via terminal to catch any error messages concerning BIMP. Would have missed it if it couldn't start.
I got the flatpak working, but I cannot get the resynthesizer nor the Gmic plugins working. I was thinking that the only major difference between this and the 2.9.9 version that Rich posted is the ability to have masks on layer groups.

I think I can deal with 2.9.9 for now. At some point I hope that Linux Mint updates Gimp in the repositories.
Gimp 2.10.2 is out, including the flatpak.

flatpak update org.gimp.GIMP

First thing it did, was update the org.gnome.Platform runtime (200MB download) before starting on Gimp 2.10.2 (50MB download). Wiped out all the additional lib files I previously installed for gmic_gimp_gtk and some other plugins Wink

No problem re-copied from my zipped archive into var/lib/flatpak/runtime/org.gnome.Platform/x86_64/3.28..etc

So far, all is good.

[Image: QdD8Sks.jpg]
Todays update Gimp 2.10.10 flatpak in my (k)ubuntu 16.04 (xenial) 


Needed to re-side-load libfiles to get some plugins working including the last of the GTK gmic's.
One file not included so updated that collection of files and plugins.

Still no QT support, I know it not the Gimp part of the flatpak but still annoying.
I do not like the alternative up-to-date appimage, maybe time to upgrade this computer to 'buntu 18.04

Forum Jump: