Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
2.10 pdf export losing fonts
#1
Photo 
I recently did a fresh install of windows & gimp.

I installed a custom font "Remington Noiseless" from the .ttf file.  The .ttf is in my C:/windows/Fonts folder. 

I created a new xcf and added the font.  It looks just right.  But when I export it to PDF the font is missing.  I've tried opening the pdf in both adobe reader and chrome.  When I look at the pdf options it shows verdana, but 

I've attached an example XCF and the resulting PDF.

With older XCFs from my old computer this font doesn't seem to work but others do.  At least I think, it's hard to tell.  The pdf fonts report seems to always claim another font than what is used.

Any suggestions?  I see a similar post here but no details https://www.gimp-forum.net/Thread-Messed...f#pid15532

Thanks for any help you might be able to offer Smile


.xcf   test-new-xcf.xcf (Size: 77.65 KB / Downloads: 70)
.pdf   test-new-xcf.pdf (Size: 44.93 KB / Downloads: 70)
Reply
#2
If you have windows and print to Microsoft Print to PDF then the characters are ok. Maybe it is a sollution for you?
Reply
#3
(12-17-2019, 06:31 PM)denzjos Wrote: If you have windows and print to Microsoft Print to PDF then the characters are ok. Maybe it is a sollution for you?

Thanks!  I tried that, but then the text wasn't selectable & the output size was quite small, it seemed to have been flattened/pasteurized...

I've tried uninstalling and reinstalling gimp and clearing the font cache but neither of those helped...
Reply
#4
Did this originally come from some other graphics application or a PDF file? The 'testing' text is a bit convoluted as well, being changed using the on canvas tool options. This using Ofnuts  font info plugin. You should really start afresh.

   

The fonts files themselves are certainly not wonderful, Hanshand in particular is has paths reversed / intersecting (according to fontforge) 

...but AFAIK that is not the problem. Shaving 1 pixel (3717 -> 3716 ) off the width of the canvas seems to cure things. This sort of thing has happened in the past. A4 at one time was weird. Remember to untick 'Layers as Pages' to get a sensible PDF.

   

Attached xcf and pdf


Attached Files
.xcf   test-new-xcf-1.xcf (Size: 77.65 KB / Downloads: 26)
.pdf   test-new-xcf-1.pdf (Size: 39.36 KB / Downloads: 47)
Reply
#5
find it really very helpful to me
Reply
#6
(12-17-2019, 07:56 PM)rich2005 Wrote: Did this originally come from some other graphics application or a PDF file? The 'testing' text is a bit convoluted as well, being changed using the on canvas tool options. This using Ofnuts  font info plugin. You should really start afresh.



The fonts files themselves are certainly not wonderful, Hanshand in particular is has paths reversed / intersecting (according to fontforge) 

...but AFAIK that is not the problem. Shaving 1 pixel (3717 -> 3716 ) off the width of the canvas seems to cure things. This sort of thing has happened in the past. A4 at one time was weird. Remember to untick 'Layers as Pages' to get a sensible PDF.



Attached xcf and pdf

Thanks!

This was a totally new file I'd started to test this.  Not imported at all.  I also didn't change the text in the canvas settings, just clicked the text entry, typed a word, selected it & set the font & font size, then tried to export.

I tried reducing the canvas size but it still wouldn't export properly.

Any suggestions what else I could do?  Is there a debug log for the pdf renderer that might have some useful information in it?

I'll attach a new file I've made with 3 fonts.  The "bahnscrift" font is working properly, but not the other two.


.xcf   test2.xcf (Size: 281.49 KB / Downloads: 36)

Update! I think I've fixed it - I uninstalled the fonts from window's font tool, then right clicked a fresh download of the font from dafont and choose 'install for all users' - now it seems to be working. I think I'd just right clicked and chosen "install" previously.

Thanks!
Reply
#7
That is working ok here as well, even at the 3717 pix width, so not that. Still wondering why you put all the text in as HansHand Italic 24 pix then change the Font and size (124) just seems a lot of work to me, but up to you

   

If you do not require the font(s) to be used by other applications the best place for the ttf file is your Gimp profile 
C:\Users\"yourname"\AppData\Roaming\GIMP\2.10\fonts

Going back a post or two, uninstalling / reinstalling Gimp rarely does anything as all the settings are held in the Gimp profile which is not uninstalled.
Reply
#8
Hello everybody
I had the same problem...
For me the solution was simple : merge all the visible layers and the fonts will be exported in the .pdf
Reply
#9
Quote:For me the solution was simple : merge all the visible layers and the fonts will be exported in the .pdf

What you actually do by merging layers is reduce all the text layers to a single bitmap layer. Your PDF is now a drawing. There is no font information saved.

All depends if you want to embed the font information in the PDF. If you do, then at-the-moment Gimp is not the tool to use.
Reply
#10
(04-05-2021, 09:00 AM)rich2005 Wrote:
Quote:For me the solution was simple : merge all the visible layers and the fonts will be exported in the .pdf

What you actually do by merging layers is reduce all the text layers to a single bitmap layer. Your PDF is now a drawing. There is no font information saved.

All depends if you want to embed the font information in the PDF. If you do, then at-the-moment Gimp is not the tool to use.

Yes, now the layers are bitmap layer, and if I don't do that, the PDF don't use my fonts.
Reply


Forum Jump: