Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Batch Image Manipulator & Curves Script
Basically, the BIMP has been a handy little tool for me to alter lots of photos quickly. However, curves is not one of the offered features. When looking around, I came across this user-made script  and tried to make it work. I don't totally understand the instructions, have gimp located both on my c and f drive (exe on F, brushes etc on C) & am using 2.8, so whether it's due to my own lack of abilities or something else, I haven't been able to make it work. I was thinking that the script could be incorporated into BIMP. When I loaded it into BIMP, it seemed to work fine and I could enter in the name of the curve file I had saved and wanted to use. Then the error message "Calling error for procedure 'script-fu-kp24-read-curves': Error: (: 1)peek-char: argument 1 must be: input port" popped up. Any ideas?
welcom to

kp24_read_curves.scm? It is now a bit on the old side - 2011-ish

If you uncomment line 138 you can get it to run from menu, and see those errors. screenshot:

The gimptalk post does indicate that it is meant to run in Gimp batch mode from a terminal rather than via some plugin such as BIMP.

Kevin is a forum moderator and I am sure he will give you advice.

If you need a GUI & BIMP then not as convenient but the gmic-gimp-qt plugin has a curves option. You can use that as other-gimp-procedure

gmic curve
gmic command in BIMP
Thanks for the reply & your help. Currently have my setup as 

[Image: 38285396056_cedb0b4512_b.jpg]
And the fx_apply is fx_apply_curve 0,105,150,-1,128,-1,128,-1,128,-1,128,255,0.7,0,0,0,0

BIMP says image was processed without any errors yet the image is never actually altered. The curve applies properly when I run it through the plugin and not BIMP.
A bit of a struggle to locate the problem.

I can not see any problem with the command you posted. Sometimes, there is a stray character right at the end, That happened to me before, check that, but the problem is...

It is a Windows / QT thing. That 'other-gimp-procedure' does not work with the Windows G'mic-QT plugin. (linux is ok)

However, it does work with the GTK version, so if you can be bothered, install that one as well. AFAIK it does co-exist with the GTK version (at least it does in Linux).

In a Win 10 VM, looks like this. Also attached the saved .bimp script in the zip file.

Your curve lightens the image a little.

An alternative, again has to use gmic_gimp_gtk plugin is the gmic script gmic_shell.scm
You can insert exactly the same command in that script (line 23). Check it on open image if you need. it is at bottom of the filters menu. If you try this, I advise getting a better text editor than notepad. Notepad++ is free and will not screw the formatting up. Script is in the zip.

In BIMP it shows up like this:

Just a note: No search facility in gmic_gimp_gtk  The curve filter is down in Testing -> Ronounours -> Curves

Attached Files
.zip (Size: 1,020 bytes / Downloads: 12)
Thanks for all your help! In the end, I think it may have been the folder I was using, but now the qt, gtk, and bimp file you provided all work. Thank you so much!

Forum Jump: