Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Can't use Huion H420 graphic tablet
I've just tried to install a Huion H420 graphic tablet on my laptop.   I can use it and the associated pen to draw in and Windows Ink Workspace, but it's not working properly in GIMP 2.8.22.    

In GIMP  I can use the pen to move the mouse pointer around and to select things and click on them.   However, I can't do any freehand drawing using the pen or brush tools.   Holding down my left mouse button and dragging the pointer round works.   Holding down the top pen button (the pen's equivalent of the left mouse button) doesn't.

What am I doing wrong?    I've tried both Window and Screen in File>Configure Input Devices for the Huion Tablet but neither seems to do what I want.
Welcome to

You are not being ignored but the fact is not many forum members use Huion Tablets so you might have to wait for one to come along.
I've been having the same issue for some time now, with 2.8.22 and as well with the development versions of 2.9.6 and 2.9.8, I even went and purchased a sub to photoshop because of this very issue about a year ago and there's been no end to it in sight. (I've recently cancelled my sub for photoshop because the software is garbage, I wouldn't suggest it as an alternative to gimp). I've also tried literally everything suggested everywhere I could find. I've tried completely reformatting my SSD and reinstalling everything from scratch, still no luck.

I recently picked up a Huion GT-191, and thought i'd give gimp a whirl again, and it was working!! however, it recently stopped working again and I'm back to square one, I'm sorry I don't have a fix for you; I too want to use gimp, and love the software, however because of this issue I just can't seem to.
I myself use a Huion H420 tablet and can bwe of aid, because I too had this EXACT problem; Basically, you need to go to Huions website directly and download their latest driver through their site for the tablet, once installed, open GIMP and check the imput devices to ensure everything works, make a new canvas and experiment!

It worked for me once I followed those steps

Forum Jump: