Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Change foreground or background color editor freezing
The color editor tool in GIMP 2.10.10 has begun freezing. I can set a new color and use the RGB sliders without a problem, but when I use the L slider GIMP freezes. The first time that happened, I was horrified to realize I'd worked at least an hour on a new project without a single save. I know better than that! But rather than lose all that work by using Task Manager to close the app, I did something else for an hour. By that time GIMP had sorted itself out.

This has happened a couple more times, and once it freezes, it will always freeze on that function. I have no idea why. I've routinely used that function in the past. 

Fiddling with it just now to see if there's a performance difference between foreground and background, I discovered that the new color is not registering in the palette at the bottom of that tool as it has always done. ??


The non grayscale colors above are all custom colors that registered yesterday.

AHA! It seems to jam in Background. And when I open Task Manager to close it, I see


Closing just the Program Plug-In does not help. It is reliably stalling with the Background Color function when using the L slider. I'd never tried the bottom sliders. They work fine with Foreground, but L, C, and h all stall out on Background.

For now, I'll swap colors and use Foreground for all color manipulation, but where are my swatches? I rely on those! Why is this behavior change occurring when I haven't changed any setting, installed any plug-ins, or whatever since before these problems began?
UPDATE: It's not just the slider. Changing the numbers on those three functions in Background Color by keyboard or arrow also freezes GIMP.
I can reproduce that but only under circumstances not mentioned in your post.

1. Why two instances of Gimp? Running Gimp with the -n switch is not unknown but is unusual.

2. Are you running in different desktops? While running multiple desktops has been around a long time in linux, only Win 10 has it as standard (used to be a separate application)

[Image: x5mPQ5P.jpg]

On desktop 2 change FG and L slider is working. Swap to desktop 1 and use it then I can get a crash.

Might be a bug in Gimp or it might be a bug in Windows.
I suggest a review of your workflow. Try to get the crash on your computer using just a single instance of Gimp.

I can reproduce that in Linux kubuntu 18.04 Gimp 2.10.10 and back to Gimp 2.10.10 in a Win10 VM
Using the -n switch or not. One Gimp or 2 instance. Eventually using the L slider causes a freeze. Might not happen at first but does after repeated use.

You could try reporting as a bug.
Thanks Rich. I noticed that double instance and started to ask about that, but it dropped out of sight while I was focused on sliders. It's not something I did on purpose, and I don't recall noticing it earlier. A few previous times I've killed a GNU plugin, which has shown at the top level right under GNU Image Manipulation Program in Task Manager, not nested as it is currently. How do I turn that -n switch off?

That may also help with the palette glitch, though for whatever reason, that's working again, without even restarting GIMP. Who knows?

Forum Jump: