Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Color Scale for specific colors (like blue and pink, for Synthwave or Retrowave)
Hello, everybody.

I've been looking on Youtube for tutorials on how to do color scales to make Synthwave image manipulations using GIMP. So far, the only videos I've found have been for doing it in Photoshop, and even then, almost all of them have been in either Spanish or Portuguese (and I speak English). For example:
It's been a compounded problem for me because there's been nothing available for Synthy/Retroey-type art. I've tried using pretty much everything in under the "Colors" tab in Gimp 2.10 (Balance, Temperature, Saturation, Shadows-Highlights, Levels, Curves, etc). I can't figure out how to make it work.

Can anybody offer any techniques?
SynthWave - Audio format?
The problem with these types of tutorial / demo is that they tend to be very specific for the image shown. Use your own and it reverts back to you, your efforts, your expertise. However, I did look at the video (very quickly) and the effect is the left side of this:


In PS a smart object was used (whatever that is). In Gimp nothing like that and there will be several ways to get some sort of result. Most are better at this than me but as a guess. Hopefully you will get better answers.
The video used color temperature to give an overall blue-ish cast. That is possible with standard Gimp. Colors -> ColorTemperature


Then a host of color corrections came up and for this I recommend installing a Gimp plugin g'mic It has a filter CMYK Tone and that gets that magenta cast added.


There will be other steps. I do not know, that gets you most of the way.

You might be able to do the whole thing with gmic. There are lots of color filters of all sorts. The best thing as with anything Gimp is experiment.  This for a sort-of retro. 


best of luck
I've tried installing G'MIC, both from the *.zip file and using dpkg -i on the *.deb file. I've added its "gmic_gimp_qt" location path as a plugin in GIMP under "Edit">"Preferences">"Folders">"Plug-ins", tried following the instructions on youtube videos and on blog posts (the official G'MIC docs are of no help whatsoever), and I can't get it to run in GIMP. How do I get this to run?

I really appreciate your help, by the way
Asking about your installation did cross my mind but only after after posting Wink

Which linux distro?

The packages are all debian based, although I can get gmic_gimp_qt running in a PClinuxOS desktop which is rpm based
Sometimes you might be missing some QT5 packages - I have seen that one before. Run Gimp from a terminal gimp --verbose and look for errors.

Are you using a flatpack (or snap)? These are sandboxed and have no QT support - gmic_gimp_qt will not work.

One work-around albeit a cumbersome one, is using a Gimp 2.10 appimage that already contains gmic.

Frequent releases here: I would try near the bottom of the list GIMP_AppImage-release-2.10.8-withplugins-x86_64.AppImage
When I installed GIMP, I used Flatpak, yes. I didn't use sudo apt, because that tends to install older versions. I'm on Ubuntu 18.04. When I ran gimp --verbose, it returned:

Command 'gimp' not found, but can be installed with:

sudo snap install gimp # version 2.10.8, or
sudo apt install gimp

See 'snap info gimp' for additional versions.

even though I definitely have GIMP installed. I'll try that, and see what happens.
read previous post again Wink

Quote:...Are you using a flatpack (or snap)? These are sandboxed and have no QT support - gmic_gimp_qt will not work...

Try the appimage

EDIT: or...Keep the flatpack Gimp 2.10.8 The default Gimp for 'buntu 18.04 is Gimp 2.8.22 Install that along side the flatpack. They co-exist, I know, I use that set-up in (k)ubuntu 16.04

Install gmic_gimp_qt for Gimp 2.8
So, installing via sudo apt -f install gimp gave me 2.8. Now, I'm downloading the app image from and making it an executable with: 

chmod a+x GIMP_AppImage-release-2.10.8-withplugins-x86_64.AppImage

Now it's running as usual, but it still doesn't have G'MIC available. Am I doing something wrong?
The appimage has the G'MIC-QT entry bottom of the Filters menu but greyed-out?

You need an image open - a blank canvas will do

The Gimp 2.8.22 is completely separate from the appimage. Any plugins go in the user profile ~/.gimp-2.8/plug-ins
The appimage user profile is separate ~/.config/GIMP-AppImage/2.10
I really wish I could take a screenshot, but Ubuntu isn't letting me. I'm using the AppImage, with a picture of a kitchen open, and no, there's no such entry at the bottom of Filters.
All I can do at the moment, is a little video demo only 3 minutes. Have a look and see if anything applies. Apologies for croaky voice, very wheezy today Wink

finished with video

Forum Jump: