Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Error installing glib-networking
I was following the installation instructions to install GIMP GIT in ' My system is Fedora 64 Cinnamon bit.

When I type:
./ --prefix=$PREFIX --disable-gtk-doc --with-gimpdir=$HOME/code/gimpdefault/install/config

 I get the following error:

configure: error:

Extra Binaries:
 gimp-console:        yes

Optional Features:
 Language selection:  no (iso-codes package not found)
 Vector icons:        yes
 Dr. Mingw (Win32):   no

Optional Plug-Ins:
 Ascii Art:           no (AA library not found)
 Ghostscript:         no (Ghostscript library not found)
 Help Browser:        no (WebKit not found)
 JPEG 2000:           yes
 MNG:                 no (MNG header file not found)
 OpenEXR:             no (OpenEXR not found)
 WebP:                no (WebP not found)
 PDF (import):        Using PostScript plug-in (libpoppler-glib not found)
 PDF (export):        yes
 Print:               yes
 Python 2:            yes
 Script-Fu:           yes
 TWAIN (Win32):       no
 Webpage:             no (WebKit not found)
 WMF:                 no (libwmf not found)
 X11 Mouse Cursor:    yes
 XPM:                 no (XPM library not found)
 Email:               yes (xdg-email)

Optional Modules:
 ALSA (MIDI Input):   no (libasound not found or unusable)
 Linux Input:         yes (GUdev support: no (libgudev not found))
 DirectInput (Win32): no

 Use xvfb-run         no (not found)
 Test appdata         no (appstream-util not found)

Error: GIMP configuration failed.

 - Error: missing dependency glib-networking
     *** Test for glib-networking failed. This is required.

See the file 'INSTALL' for more help.

Configure failed or did not finish!
What should I do to fix this error?

ps: When I do  
dnf install glib-networking

I get:
Package glib-networking-2.50.0-2.fc26.x86_64 is already installed, skipping.
Package glib-networking-2.50.0-2.fc26.i686 is already installed, skipping.
Dependencies resolved.
Nothing to do.
There is no glib-networking-devel as far as I know.
Try looking for libgiognutls rather than glib-networking I think it is part of that.

edit: A bit of a search around and there is reference to a glib-networking issue when compiling for Windows.

Have you asked on a Fedora forum? or I think there are some Fedora users on might br worth asking for advice there.
Thanks, they have helped me out in that Forum. Here is how I solved it:
I replaced the line 
export GIO_EXTRA_MODULES=/usr/lib/gio/modules


export GIO_EXTRA_MODULES=/usr/lib64/gio/modules

This is a necessary for the Fedora system. Other systems like ubuntu and debian also require a different export variable. Check the link

Forum Jump: