Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Exclamation mark feathering menu
Hi folks, originally posted to another GIMP forum until I realized no longer active.

Total newbie here following tutorials for background blurring.

Only issue appears to be the exclamation mark at the 'feathering' step, the defaults appear to have changed but cannot find anywhere a reason for red triangle - results vary on two different machines with same GIMP 2.10.8 and OS, Win 2010 Pro.

Tried various images and ratios thinking it could have something to do with aspect, and or ratio with background image -

Accessing the online help doesn't give any clues either, help appreciated.

URL to tutorial?

It does seem to work even though GIMP changes your default selection (at 3.21 in video) possibly due to warning?
That video is Gimp 2.8, it uses a layer mask, maybe not the exact procedure I would use but it is ok.

I cannot get that 'exclamation' mark error for feather, I suppose it will be something about the selection. Gimp 2.10 free select tool does not 'join' the same way as Gimp 2.8. You have to activate it by hit enter key or click inside selection or choose another tool.

The other thing is you can apply a feather directly in the free select dialogue, in this case no need to apply separately

The sequence might go like this:
Duplicate layer Layer -> Duplicate Layer Apply Gaussian blur Filters -> Blur -> Gaussian Blur screenshot:

Turn top layer visibility off, Choose the free select tool, tick the feather edges option, make the selection, hit the enter key:

Turn the top layer visibility back on. Create a layer mask Layer -> Mask -> Create Layer Mask Choose a white option. Depending if you click on the layer icon or the layer mask icon in the layers dialogue determines which is active. The active one has a white border. Not easy to see with a white layer mask Wink Practice clicking in one or the other to see the change.

With layer mask active, paint (quicker way is fill) over the selection in black to uncover the layer below:

Turn off the selection Select -> None and clean up the edges, still painting on the layer mask. Hint - ctrl-x swaps FG/BG white to hide, black to show.

Save your work as a Gimp xcf file in case you want to re-edit any time. Exporting as a png or jpg will flatten the image to a single layer.

Using layer masks is used in all sorts of image editing. Worth while knowing how it works.
Exclamation Mark? Red triangle? I don't remember seeing anything like this in Gimp?  (screenshots?)?

Me, I would be very suspicious of a tutorial that:
  • uses a large brush to fill a selection (instead of using the bucket-fill)
  • uses the freehand selector for such a complex selection (note the acceleration...). The scissors are likely a better tool in this case. The Path tool would be even better.
Also, this doesn't give the look of a "shallow depth of field", this gives the look of a girl put over a blurred picture, because in a real picture with shallow depth of field, the part of the wall where she sits would be in focus, and therefore sharp, and would blur progressively as the distance from the subject increases.

Basically, for this kind of effect:
  • duplicate the layer
  • blur the top layer
  • make the top layer as transparent as you want the picture to be sharp.This is the difficult part. The only good point of the tutorial is that it uses a layer mask for this. But if you are goint to paint over all the imperfections of the selection, then you don't need the selection. This also allows you to paint with a gray gradient the areas where you want a progressive blur.
Otherwise, Gimp has a "focus blur" plugin: you define a "distance map" on a layer and it does the rest.
Thanks for the incredibly detailed replies. much appreciated.

Let me try those techniques and feedback.
I tried a few variations using different images in case the resolution or metadata was causing an issue. When loading some  of the original images GIMP asked to rotate mentioning file contained extra info.

It still seems to work but GIMP changes the defaults as mentioned earlier, screen shot attached - please note also my error, its actually a question mark rather than exclamation symbol.

This is just a test shot to show settings - later on will experiment with both of the recommendations above.[Image: 2019-03-03.png]
Nice one Wink That is a first. 5001.000 pix Probably larger than the image.

Should be something roundabout 5 pixels - depending on the image.


If you highlight the value you can enter a small number from the keyboard.

keep experimenting, it is the best way to learn Gimp.
(03-03-2019, 06:46 PM)rich2005 Wrote: Nice one Wink That is a first. 5001.000 pix Probably larger than the image.

Should be something roundabout 5 pixels - depending on the image.

If you highlight the value you can enter a small number from the keyboard.

keep experimenting, it is the best way to learn Gimp.

Yup, it did seem incorrect although that's the default value which GIMP fills in (tutorial mentions using default) - changing it to 5,000 removes the outline altogether?
One of the problems with the default gimp setup is it "remembers" last used settings and tools.

The default setting is actually one pixel. You must have entered 5000 sometime previously

What you want is 5 point 000

Just enter 5 Gimp will add the point 000

edit: guessing that is how you got the 1.
Swipe the value with the mouse to highlight. Then keyboard a 5 Use the little up-down arrows in the feather dialogue to adjust if required.

Forum Jump: