Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
G'MIC Qt installation problem
Ubuntu 18.04 installed on laptop. Gimp from otto-kesselgulasch. Installed G'MIC - does not appear in menu.

Starting Gimp from terminal error message:
"/home/david/.config/GIMP/2.10/plug-ins/gmic_gimp_qt: /usr/lib/x86_64-linux-gnu/ version `Qt_5.10' not found (required by /home/david/.config/GIMP/2.10/plug-ins/gmic_gimp_qt"

I compared the libQt5 files of my desktop with those on the laptop and installed the missing ones using Synaptic. Still no G'MIC and the same error message.

Curiously, if I start Gimp from the terminal on the desktop, I get the identical error message but G'MIC works!!!

Any help and advice gratefully received.

Did you get the gmic_gimp_qt from the site? ie one of the linux packages. These are for either debian sid or ubuntu cosmic and produce that error. Ubuntu 18.04 (bionic) uses an older version of QT. Up to you if you want to mess around with QT versions but IMHO not a good idea.

I keep compiled versions of gmic_gimp_qt for Ubuntu 18.04 (bionic) here:

Try one of those. Working ok here in Gimp 2.10.10 and kubuntu 18.04
Many thanks for your help - problem solved!
I fitted a spare SSD to an old laptop to try and make it more usable, which is why I have been re-installing OS and the other packages I use.

Forum Jump: