Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
gmic_gimp_qt and Ubuntu 18.04
Using 'buntu 18.04 (or Mint19) with Gimp 2.10.x and not able to run the latest and greatest gmic_gimp_qt plugin from ?

The reason is the version of QT5 that comes with 'buntu 18.04 is 2.9.5 and the 'official' plugin requires 2.10

Run gimp from a terminal and 

Quote:.config/GIMP/2.10/plug-ins/gmic_gimp_qt: /usr/lib/x86_64-linux-gnu/ version `Qt_5.10' not found (required by /home/rich/.config/GIMP/2.10/plug-ins/gmic_gimp_qt)
gimp: LibGimpBase-WARNING: gimp: gimp_wire_read(): error

The solution, compile gmic_gimp_qt for Gimp 2.10 in a ubuntu 18.04 environment: 

Many linux users maybe not interested in compiling from scratch so I will start off with these as downloads. 
The usual applies. Un-zip, put in your Gimp profile ~/.config/GIMP/2.10/plug-ins check that they are still executable.

Previous stable 2.5.7

Previous stable  2.6.1

Previous stable 2.6.2

Previous stable  2.6.4

Previous stable 2.6.5

Previous stable 2.6.6

Previous stable 2.6.8

Previous Stable 2.7.0

Previous Stable 2.7.1

Previous Stable 2.7.2  (23 - Sept - 19)

Previous Stable 2.7.3  (8 - Oct - 19)

Stable  2.7.5 (25-Oct-19)

I will put this up just to continue the sequence. From what I read not much new is going to be added to gmic_gimp. All work going into the stand-alone version. The underlying code has changed so there might be some old filters that do not work. If you are happy with a previous version maybe stick with it for now.

Stable 2.8.0 (updated 4 Dec 19)

Stable 2.8.1  (updated 20 Dec 19)

Stable 2.8.2  (updated 23 Jan 20)

Stable 2.8.4  (updated 7 Feb 20)

Stable 2.9.0  (updated 27 March 20)

Stable 2.9.1  (updated 6 June 20)

Stable 2.9.2 (updated 3 September 20)

Stable 2.9.3  (updated 14 November 20)

Stable 2.9.4 (24 November 20)

Current Stable 2.9.5 (updated 06 February 21)

I will try and keep updated as gmic progresses.

Note: QT5 is required and might not be installed, usually the following is enough to pull in the required packages.

sudo apt install libqt5core*  libqt5widgets5*
Thank you VERY VERY much !!!
Thanks a lot!

I get

./gmic_gimp_qt-270: error while loading shared libraries: cannot open shared object file: No such file or directory

Ubuntu 18.04 only provides libgegl-0.3. If I try to download and install libgegl-0.4 (downloaded from the debian package website, I get a dozen of unmet dependencies and I really don'r want to go down that rabbit hole....

Is there a solution for this?
The plugin is for Gimp 2.10.x that is installed from the otto-kesselgulasch/gimp PPA This also contains the required (by Gimp) gegl 0.4


For Gimp 2.10 installation hints, see:

(A general note for users) If you are using Gimp 2.8. This is not the version for you. Use the 2.8 version from

If you are using a Gimp 2.10.x flatpak or snap, then these do not support QT required by the gmic_gimp_qt plugin. The plugin will not work.

No use trying to run the plugin, has to be used from within Gimp 2.10. If you want the standalone gmic application again use a package from

thanks, that was the problem, I had installed via flatpak. Now I upgraded to 19.04 in spite of not being LTS. But there were several packages where I needed a newer version.

Thanks for the explanation anyways.


Forum Jump: