Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
gmic_gimp_qt and Ubuntu 18.04
#1
Using 'buntu 18.04 (or Mint19) with Gimp 2.10.x and not able to run the latest and greatest gmic_gimp_qt plugin from http://www.gmic.eu ?

The reason is the version of QT5 that comes with 'buntu 18.04 is 2.9.5 and the 'official' gmic.eu plugin requires 2.10

Run gimp from a terminal and 

Quote:.config/GIMP/2.10/plug-ins/gmic_gimp_qt: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.10' not found (required by /home/rich/.config/GIMP/2.10/plug-ins/gmic_gimp_qt)
gimp: LibGimpBase-WARNING: gimp: gimp_wire_read(): error

The solution, compile gmic_gimp_qt for Gimp 2.10 in a ubuntu 18.04 environment: 

Many linux users maybe not interested in compiling from scratch so I will start off with these as downloads. 
The usual applies. Un-zip, put in your Gimp profile ~/.config/GIMP/2.10/plug-ins check that they are still executable.

Previous stable 2.5.7 https://my.pcloud.com/publink/show?code=...lSy8iure0y

Previous stable  2.6.1 https://my.pcloud.com/publink/show?code=...goSXubiCwy

The current stable 2.6.2  https://my.pcloud.com/publink/show?code=...XomYEgwThk

I will try and keep updated as gmic progresses.

Note: QT5 is required and might not be installed, usually the following is enough to pull in the required packages.

Code:
sudo apt install libqt5core*  libqt5widgets5*
Reply
#2
Thank you VERY VERY much !!!
Reply


Forum Jump: