Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
gmic_gimp_qt and Ubuntu 18.04
#1
Using 'buntu 18.04 (or Mint19) with Gimp 2.10.x and not able to run the latest and greatest gmic_gimp_qt plugin from http://www.gmic.eu ?

The reason is the version of QT5 that comes with 'buntu 18.04 is 2.9.5 and the 'official' gmic.eu plugin requires 2.10

Run gimp from a terminal and 

Quote:.config/GIMP/2.10/plug-ins/gmic_gimp_qt: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.10' not found (required by /home/rich/.config/GIMP/2.10/plug-ins/gmic_gimp_qt)
gimp: LibGimpBase-WARNING: gimp: gimp_wire_read(): error

The solution, compile gmic_gimp_qt for Gimp 2.10 in a ubuntu 18.04 environment: 

Many linux users maybe not interested in compiling from scratch so I will start off with these as downloads. 
The usual applies. Un-zip, put in your Gimp profile ~/.config/GIMP/2.10/plug-ins check that they are still executable.

Previous stable 2.5.7 https://my.pcloud.com/publink/show?code=...lSy8iure0y

Previous stable  2.6.1 https://my.pcloud.com/publink/show?code=...goSXubiCwy

Previous stable 2.6.2  https://my.pcloud.com/publink/show?code=...XomYEgwThk

Previous stable  2.6.4 https://my.pcloud.com/publink/show?code=...RFPp7zKb07

Previous stable 2.6.5 https://my.pcloud.com/publink/show?code=...nRAXk5zKnV

Previous stable 2.6.6 https://my.pcloud.com/publink/show?code=...p2Aua2bjsX

Previous stable 2.6.8 https://my.pcloud.com/publink/show?code=...OxEJtfCIUX

Current Stable 2.7.0 https://my.pcloud.com/publink/show?code=...JvWuPhc6uV updated 14 August 2019

I will try and keep updated as gmic progresses.

Note: QT5 is required and might not be installed, usually the following is enough to pull in the required packages.

Code:
sudo apt install libqt5core*  libqt5widgets5*
Reply
#2
Thank you VERY VERY much !!!
Reply
#3
Thanks a lot!

I get

Code:
./gmic_gimp_qt-270: error while loading shared libraries: libgegl-0.4.so.0: cannot open shared object file: No such file or directory



Ubuntu 18.04 only provides libgegl-0.3. If I try to download and install libgegl-0.4 (downloaded from the debian package website, I get a dozen of unmet dependencies and I really don'r want to go down that rabbit hole....

Is there a solution for this?
Reply
#4
The plugin is for Gimp 2.10.x that is installed from the otto-kesselgulasch/gimp PPA This also contains the required (by Gimp) gegl 0.4

   

For Gimp 2.10 installation hints, see: https://www.gimp-forum.net/Thread-Gimp-2...-18-04-LTS

(A general note for users) If you are using Gimp 2.8. This is not the version for you. Use the 2.8 version from http://www.gmic.eu

If you are using a Gimp 2.10.x flatpak or snap, then these do not support QT required by the gmic_gimp_qt plugin. The plugin will not work.

No use trying to run the plugin, has to be used from within Gimp 2.10. If you want the standalone gmic application again use a package from http://www.gmic.eu
Reply
#5
Hello,

thanks, that was the problem, I had installed via flatpak. Now I upgraded to 19.04 in spite of not being LTS. But there were several packages where I needed a newer version.

Thanks for the explanation anyways.

Cheers
Reply


Forum Jump: