Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
G'MIC-Qt preview error
I am not sure what is wrong. Is there a fix for this ? I was using @rich2005 's the G'MIC plugin. I just removed that to check but this preview error exists with the default AppImage with Plugins version : GIMP_AppImage-git-2.10.25-20210408-withplugins-x86_64

Gimp appimage with plugins. The version of the gmic plugin is (for gmic) quite old. Version 2.9.2_pre#200703 (3 July 20) and the gmic syntax has changed since then, (even from version 2.9.6)

This should work, just tried it with a Gimp 2.10.25-with plugins appimage.

Get the up-to-date plugin version 2.9.8 from my storage, download link:
The thread with versions is  you can always check there.

Unzip, put the plugin gmic_gimp_qt-298 in your appimage profile ~/.config/GIMP-AppImage/2.10/plug-ins/ and that should supercede the older plugin.  Run the update to get 568 filters (as of today)

Works here: but as always you might need extras such as some QT5 packages.

Hi, is it the same Qt plugin you suggested from the other site ? I am using it ever since. Is the mentioned Qt plugin a new one ? Looks like both are 2.9.8. I did just as you said, kept it in the plug-in folder. But there is no G'MIC menu at all now. This was the issue when I tried 2.98 the first time from the download. I must be doing something wrong. But if I place it inside the plug-in folder, it does not work at all. But if I place it inside the Scripts folder, I can use G'MIC inside GIMP. Not sure where the error is. Thanks.
Quote:Is the mentioned Qt plugin a new one ? Looks like both are 2.9.8.

It is a more recent version that the one from gimpchat. Some bug-fixes. (I might recompile today, I will check on the source, maybe something new) Moving it to the scripts folder will disable it just as much as deleting it. A plugin goes in the plugins folder.

Quote:...Not sure where the error is. Thanks.

Who knows ?  With the 2.9.8 plugin in the plugins folder (and check that it is executable) you could run the appimage in a terminal and try to find the error messages associated with the plugin. However it generates so much output that you might not find any missing dependencies.

It is probably a qt5 dependency. As a starter, try in terminal

sudo apt install libqt5widgets5

and hope that pulls in required files.
Thanks @rich2005

All I had to do was to use the file shared on this thread. The one I got through GC might have some problem. Everything is good and fine now and I am able to get the preview without any issues Smile

Forum Jump: