Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
GIMP 2.10 Won't print picture in selected size
I'm making correction and text additions to numerous photographs. All are imported from JPG files and set to 8 1/2 X 11 inch landscape at 300 dpi.
After making the necessary edits I save the picture in GIMP's default XCF file format. I then check the image size and canvas size to make sure they are the same, usually 8 1/4 X 10 3/4 inches to account for printer margins. I then print out a sample on plain paper. I'll use either an HP Envy 5055 inkjet or our Konica-Minolta bizhub C558. I'll check all the setting of the printers and then print.

I've yet to get a print that is 8 1/4 X 10 3/4. The print is usually 6 1/5 X 8 3/4. What gives?
Just a bit of background, Gimp is developed in linux, the Gimp developers use linux, linux uses a different printing system to Windows.
For Windows there is an additional plugin 'winprint' I don't think it has much changed in years, just gets 'bolted-on' by the two or three people who actually compile the Windows Gimp.

I am a very-occasional Win user, I do all my printing in linux so please take the following as just 'maybe / might work'

A screenshot for reference.

(1) A 300 ppi US letter size image (landscape) with print size set to 10.5 x 8.25 gives a printing resolution of 309 ppi
(2) Nice printers you have, I assume they are all set up as required.
(3) In the print dialog it looks to me that all you get is a portrait option shrinking the size to 8 x 6 @ 412 ppi Your printer setup might print this Landscape and Centered ( I do not know)

Next screenshot:

(4) If Gimp wants to print Portrait, let it. Rotate the image 90 deg and the print dialog now shows almost 8 x 10 @ 323 ppi Why not 309 ppi ? The printer imposes a wider margin at the bottom required for paper feed. All depends on the printer. You can set ignore Page margins and risk a truncated print.

EDIT: Told you I was just an occasional Win user. Totally forgot that the page setup is separate from the Print dialogue (unlike linux) Did you set up something like this: Still not working ? Jump to the end for alternatives.

Just in case you are not using Gimp 2.8 but are using Gimp 2.10 screenshot:

Just the same as for Gimp 2.8 but the bottom of the print dialogue is cut off. This is a function of the dark / grey themes. Go into Edit -> Preferences ->Themes and set the theme to 'System'

Alternatives and better bets Wink
Do not use Gimp for printing. Use some other application such as XnView or IrfanView.
Print from Gimp to a PDF. Use a PDF viewer program for printing.

Seem to recall the last time I tried printing from a Windows Gimp. The exact opposite of the problem. Wanted a 6x4 print, all I could get was a full page (A4)

Forum Jump: